aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
diff options
context:
space:
mode:
authorSamuli Piippo <samuli.piippo@gmail.com>2023-11-08 18:39:06 +0000
committerKhem Raj <raj.khem@gmail.com>2023-11-11 09:26:41 -0800
commitca4c5ab653b9d5187385050552386f95ec868944 (patch)
tree2c37f846fa6f743eea2a2b21fc4ed410612199bc /meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
parent15df8b4e802cfb29ba3d1aff2b446f376d97501b (diff)
downloadmeta-openembedded-contrib-ca4c5ab653b9d5187385050552386f95ec868944.tar.gz
abseil-cpp: fix mingw build
Add patch to fix mingw build of abseil-cpp undefined reference to `absl::lts_20230802::synchronization_internal::Win32Waiter::Poke()' undefined reference to `absl::lts_20230802::synchronization_internal::Win32Waiter::Win32Waiter()' undefined reference to `absl::lts_20230802::synchronization_internal::Win32Waiter::Post()' undefined reference to `absl::lts_20230802::synchronization_internal::Win32Waiter::Poke()' and include bindir to recipe sysroot to fix protobuf build. | The imported target "absl::log_severity" references the file | | "../nativesdk-protobuf/4.23.4/recipe-sysroot/usr/local/oe-sdk-hardcoded-buildpath/sysroots/x86_64-w64-mingw32/usr/bin/libabsl_log_severity.dll" | | but this file does not exist. Signed-off-by: Samuli Piippo <samuli.piippo@qt.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index 5003187d0d..65ecab7d08 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -15,6 +15,7 @@ SRC_URI = "git://github.com/abseil/abseil-cpp;branch=${BRANCH};protocol=https \
file://0002-Remove-maes-option-from-cross-compilation.patch \
file://abseil-ppc-fixes.patch \
file://0003-Remove-neon-option-from-cross-compilation.patch \
+ file://0004-Avoid-using-both-Win32Waiter-and-PthreadWaiter-on-Mi.patch \
"
S = "${WORKDIR}/git"
@@ -32,4 +33,6 @@ EXTRA_OECMAKE = "-DBUILD_SHARED_LIBS=ON \
BBCLASSEXTEND = "native nativesdk"
+SYSROOT_DIRS:append:class-nativesdk:mingw32 = " ${bindir}"
+
FILES:${PN}-dev += "${includedir} ${libdir}/cmake ${libdir}/pkgconfig"