aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-03-07 12:11:41 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:56:44 +0100
commit29cc9583e3ccb1056b5cf3411c23bd5527c23a25 (patch)
tree782c04dd1f09eb346427065adbcb8a4b7eca4061 /meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
parentcc9fd968ca301cf4c6cbd75edadc042ffabcea98 (diff)
downloadmeta-openembedded-contrib-29cc9583e3ccb1056b5cf3411c23bd5527c23a25.tar.gz
json-spirit: add new recipe
Json Spirit is a C++ JSON parser/generator implemented with Boost Spirit. It's being required by another newly added recipe librcf. The source json_spirit_v4.08.zip is derived from: https://www.codeproject.com/KB/recipes/JSON_Spirit/json_spirit_v4.08.zip The reason for getting it from a zip file instead of fetching it from the above site is that it needs logging in firstly before you can download anything. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb')
-rw-r--r--meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb b/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
new file mode 100644
index 0000000000..dff6cc1614
--- /dev/null
+++ b/meta-oe/recipes-devtools/json-spirit/json-spirit_4.08.bb
@@ -0,0 +1,24 @@
+SUMMARY = "A C++ JSON Parser/Generator Implemented with Boost Spirit."
+DESCRIPTION = "JSON Spirit, a C++ library that reads and writes JSON files or streams. \
+It is written using the Boost Spirit parser generator. If you are \
+already using Boost, you can use JSON Spirit without any additional \
+dependencies."
+HOMEPAGE = "https://www.codeproject.com/kb/recipes/json_spirit.aspx"
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=278ef6183dec4aae1524fccc4b0113c9"
+
+SRC_URI = "file://json_spirit_v${PV}.zip \
+ file://0001-Adjust-the-cmake-files.patch \
+"
+
+S = "${WORKDIR}/json_spirit_v${PV}"
+
+DEPENDS = "boost"
+
+inherit cmake
+
+FILES_${PN}-dev += "${datadir}/cmake/Modules/FindLibJsonSpirit.cmake"
+
+BBCLASSEXTEND += "nativesdk"