aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@cn.fujitsu.com>2020-03-24 23:47:17 -0700
committerKhem Raj <raj.khem@gmail.com>2020-03-25 06:52:29 -0700
commitbe3f961493ae98b5d1796a51a7108674ef7672f6 (patch)
tree5487a975aed5440a3b30091ba3cafd71ebe2ee3a /meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb
parent7efc50a47c2d686076405a48ce8e7426b30791f4 (diff)
downloadmeta-openembedded-contrib-be3f961493ae98b5d1796a51a7108674ef7672f6.tar.gz
lapack: upgrade 3.8.0 -> 3.9.0
Signed-off-by: Wang Mingyu <wangmy@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb')
-rw-r--r--meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb b/meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb
new file mode 100644
index 0000000000..56c01c533d
--- /dev/null
+++ b/meta-oe/recipes-devtools/lapack/lapack_3.9.0.bb
@@ -0,0 +1,24 @@
+SUMMARY = "Linear Algebra PACKage"
+URL = "http://www.netlib.org/lapack"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=930f8aa500a47c7dab0f8efb5a1c9a40"
+
+# Recipe needs FORTRAN support (copied from conf/local.conf.sample.extended)
+# Enabling FORTRAN
+# Note this is not officially supported and is just illustrated here to
+# show an example of how it can be done
+# You'll also need your fortran recipe to depend on libgfortran
+#FORTRAN_forcevariable = ",fortran"
+#RUNTIMETARGET_append_pn-gcc-runtime = " libquadmath"
+
+DEPENDS = "libgfortran"
+
+SRC_URI = "https://github.com/Reference-LAPACK/lapack/archive/v${PV}.tar.gz"
+SRC_URI[md5sum] = "0b251e2a8d5f949f99b50dd5e2200ee2"
+SRC_URI[sha256sum] = "106087f1bb5f46afdfba7f569d0cbe23dacb9a07cd24733765a0e89dbe1ad573"
+
+EXTRA_OECMAKE = " -DBUILD_SHARED_LIBS=ON "
+OECMAKE_GENERATOR = "Unix Makefiles"
+
+inherit cmake pkgconfig
+EXCLUDE_FROM_WORLD = "1"