aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/memstat
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-03-19 22:31:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-31 13:25:58 +0200
commitcafa3a45425108ecbae0ef9324a6228c145fc9f8 (patch)
treeb6a8cbaf8c6f2a36dc9386205992e826b3ea038a /meta-oe/recipes-devtools/memstat
parentbfc16ec09d18b468f7dd73d8fca2c199d9c55417 (diff)
downloadmeta-openembedded-contrib-cafa3a45425108ecbae0ef9324a6228c145fc9f8.tar.gz
memstat: Fix build with musl
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/memstat')
-rw-r--r--meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch29
-rw-r--r--meta-oe/recipes-devtools/memstat/memstat_1.0.bb3
2 files changed, 31 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch b/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch
new file mode 100644
index 0000000000..9a0a17e0e4
--- /dev/null
+++ b/meta-oe/recipes-devtools/memstat/memstat/0001-Include-limits.h-for-PATH_MAX-definition.patch
@@ -0,0 +1,29 @@
+From 4b6c957372314562bf7b9117103e3a08643eb7b8 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Sat, 18 Mar 2017 17:47:28 -0700
+Subject: [PATCH] Include limits.h for PATH_MAX definition
+
+Fixes
+
+error: use of undeclared identifier 'PATH_MAX'
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ memstat.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/memstat.c b/memstat.c
+index 5039fb0..3ff6ee4 100644
+--- a/memstat.c
++++ b/memstat.c
+@@ -19,6 +19,7 @@
+ #include <unistd.h>
+ #include <getopt.h>
+ #include <errno.h>
++#include <limits.h>
+
+ /* blacklist devices that just map physical memory */
+ char *blacklist[] = {
+--
+2.12.0
+
diff --git a/meta-oe/recipes-devtools/memstat/memstat_1.0.bb b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
index 825215372c..91a9200c34 100644
--- a/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
+++ b/meta-oe/recipes-devtools/memstat/memstat_1.0.bb
@@ -13,7 +13,8 @@ S = "${WORKDIR}/memstattool"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=87be186443b1ac2cfa466f475e1ee0cb"
SRC_URI = "http://sourceforge.net/projects/memstattool/files/memstat_${PV}.tar.gz \
- "
+ file://0001-Include-limits.h-for-PATH_MAX-definition.patch \
+ "
SRC_URI[md5sum] = "2c3acc0c62b2a18f6601b84e54aa7462"
SRC_URI[sha256sum] = "245d5fc7fb87bcfd14486cd34917cae2856e799559ac568434af12c4852bce94"