aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/pmtools
diff options
context:
space:
mode:
authorJagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com>2015-08-19 15:52:56 +0530
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-31 19:43:44 +0200
commit14c8b506cab9e5c741d01cf6ea3c07f3fdb6c1aa (patch)
tree9ae35f9bbc56df14a6c293727f16ab28ff2f9755 /meta-oe/recipes-devtools/pmtools
parent227aa6c63b4acd65a5b924aa41ceccac0989b6b3 (diff)
downloadmeta-openembedded-contrib-14c8b506cab9e5c741d01cf6ea3c07f3fdb6c1aa.tar.gz
pmtools: add new recipe
pmtools contains small collection of power management test and investigation tools, acpidump - dump a system’s ACPI tables to an ASCII file acpixtract - convert ASCII acpidump output to raw binary table madt - parser for ACPI table Signed-off-by: Jagadeesh Krishnanjanappa <jkrishnanjanappa@mvista.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/pmtools')
-rw-r--r--meta-oe/recipes-devtools/pmtools/pmtools_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
new file mode 100644
index 0000000000..602da5e207
--- /dev/null
+++ b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "This is a small collection of power management \
+ test and investigation tools"
+HOMEPAGE = "http://lesswatts.org/projects/acpi"
+LICENSE = "GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
+
+PV = "20130209+git${SRCPV}"
+
+SRC_URI = "git://github.com/anyc/pmtools.git;protocol=https"
+SRCREV = "3ebe0e54c54061b4c627236cbe35d820de2e1168"
+
+COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
+
+S = "${WORKDIR}/git"
+
+do_configure[noexec] = "1"
+do_compile() {
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir} ${D}${docdir}
+ install -m 755 ${S}/acpidump/acpidump ${D}${bindir}
+ install -m 755 ${S}/acpixtract/acpixtract ${D}${bindir}
+ install -m 755 ${S}/madt/madt ${D}${bindir}
+ install -m 644 ${S}/README ${D}${docdir}
+}