aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-11-02 09:58:09 +0100
committerKoen Kooi <koen@dominion.thruhere.net>2011-11-02 11:06:10 +0100
commit409d1973152d4b75146d0ff58b1857a12e500cf7 (patch)
treecaccb0629cc9c83b74f67c138cfd2c92b788a3c9 /meta-oe/recipes-devtools/python
parent239e817197b287e1a3dc981737543fb9460999e6 (diff)
downloadmeta-openembedded-contrib-409d1973152d4b75146d0ff58b1857a12e500cf7.tar.gz
python-pyopenssl: import from OE classic, update to 0.13
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb23
-rw-r--r--meta-oe/recipes-devtools/python/python-tornado_git.bb4
2 files changed, 25 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
new file mode 100644
index 0000000000..f2d6d9ed9e
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Simple Python wrapper around the OpenSSL library"
+SECTION = "devel/python"
+
+LICENSE = "Apache"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCNAME = "pyOpenSSL"
+
+DEPENDS = "openssl"
+
+SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
+SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
+SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+PACKAGES =+ "${PN}-tests"
+FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"
+
+RDEPENDS_${PN} = "python-threading"
+RDEPENDS_${PN}-tests = "${PN}"
diff --git a/meta-oe/recipes-devtools/python/python-tornado_git.bb b/meta-oe/recipes-devtools/python/python-tornado_git.bb
index ebbc7d1e22..b630785c57 100644
--- a/meta-oe/recipes-devtools/python/python-tornado_git.bb
+++ b/meta-oe/recipes-devtools/python/python-tornado_git.bb
@@ -3,8 +3,8 @@ LICENSE = "Apache"
LIC_FILES_CHKSUM = "file://README;md5=e7fb9954003d7cd93322ccf282210d1c"
PV = "2.1.1"
-PR = "r1"
-SRCREV = "970b43bddf276d7ce0022252709fcac1ff1f8c64"
+PR = "r2"
+SRCREV = "066a0c38fb819419b8422980b61a0fd2f6ee4739"
SRC_URI = "git://github.com/facebook/tornado.git"
S = "${WORKDIR}/git"