aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorNoor Ahsan <noor_ahsan@mentor.com>2011-09-06 20:17:58 +0000
committerKoen Kooi <koen@dominion.thruhere.net>2011-09-07 10:38:26 +0200
commit5e2cdae237f2093f9b592277c9419b6f0275feb5 (patch)
treeaa80870f571610136e1a8eb681c9270061df5f47 /meta-oe/recipes-devtools/python
parentcdff22f41acca435f909cc4f564e254daf8bff9e (diff)
downloadmeta-openembedded-contrib-5e2cdae237f2093f9b592277c9419b6f0275feb5.tar.gz
python-lxml: Add version 2.2.8 (initial recipe)
* Imported from oe.dev commit id bc6a94559157e6fcc190a22a259c0f757b8664ae. * Getting "skipping incompatible libraries" message in compilation log. Fixed that issue by changing --with-xml2-config=${STAGING_BINDIR_NATIVE}/xml2-config to --with-xml2-config=${STAGING_BINDIR_CROSS}/xml2-config. * Added BBCLASSEXTEND native and nativesdk for native recipe. * Tested with MACHINE = 'qemuppc' Signed-off-by: Noor Ahsan <noor_ahsan@mentor.com> Reviewed-by: Paul Menzel <paulepanter@users.sourceforge.net> Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb
new file mode 100644
index 0000000000..e19c776359
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python-lxml_2.2.8.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Powerful and Pythonic XML processing library combining \
+libxml2/libxslt with the ElementTree API."
+HOMEPAGE = "http://codespeak.net/lxml"
+LICENSE = "BSD"
+LIC_FILES_CHKSUM = "file://LICENSES.txt;md5=7de92baeb3b7bfaebe72404155fdb346"
+SRCNAME = "lxml"
+
+DEPENDS = "libxml2 libxslt"
+RDEPENDS_${PN} += "libxml2 libxslt python-compression"
+
+SRC_URI = "http://pypi.python.org/packages/source/l/${SRCNAME}/${SRCNAME}-${PV}.tar.gz;name=lxml"
+SRC_URI[lxml.md5sum] = "d6c612d63a84d79440912a1b29d3b981"
+SRC_URI[lxml.sha256sum] = "89b73925b5e3295dcf4675cb948007a20eb029fe35c9a162ae19ec11f1abafe5"
+
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit setuptools
+
+DISTUTILS_BUILD_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+DISTUTILS_INSTALL_ARGS += " \
+ --with-xslt-config='${STAGING_BINDIR_NATIVE}/pkg-config libxslt' \
+ --with-xml2-config='${STAGING_BINDIR_CROSS}/xml2-config' \
+"
+
+BBCLASSEXTEND = "native nativesdk"
+RDEPENDS_${PN}_virtclass-native = "libxml2-native libxslt-native"
+
+
+