aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2015-03-17 20:54:12 -0600
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:30 +0100
commitdf6c7b1279790d27ebfd58fbdfbac89bde5782ec (patch)
tree01fe96ea38d75c46f9d384a83e5c85933991ce45 /meta-oe/recipes-devtools/python
parent7e2911a0e99ff66adb7999931107761298a5b3fe (diff)
downloadmeta-openembedded-contrib-df6c7b1279790d27ebfd58fbdfbac89bde5782ec.tar.gz
python-pyopenssl: Upgrade to 0.14
This upgrade will match with the openssl 1.0.2 changes The newer verion of pyopenssl now uses setuptools instead of distutils Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-pyopenssl_0.14.bb (renamed from meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb)8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb b/meta-oe/recipes-devtools/python/python-pyopenssl_0.14.bb
index 01f43da271..1f609e36f5 100644
--- a/meta-oe/recipes-devtools/python/python-pyopenssl_0.13.bb
+++ b/meta-oe/recipes-devtools/python/python-pyopenssl_0.14.bb
@@ -7,15 +7,15 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
SRCNAME = "pyOpenSSL"
DEPENDS = "openssl"
-PR = "r1"
SRC_URI = "http://pypi.python.org/packages/source/p/pyOpenSSL/pyOpenSSL-${PV}.tar.gz"
-SRC_URI[md5sum] = "767bca18a71178ca353dff9e10941929"
-SRC_URI[sha256sum] = "21e12b03abaa0e04ecc8cd9c251598f71bae11c9f385304234e4ea5618c6163b"
+
+SRC_URI[md5sum] = "8579ff3a1d858858acfba5f046a4ddf7"
+SRC_URI[sha256sum] = "a99db8e59c120138ad8a72eecedcc24b4510d2eed3ce48213b7e32f22cc4ee6e"
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit distutils
+inherit setuptools
PACKAGES =+ "${PN}-tests"
FILES_${PN}-tests = "${libdir}/${PYTHON_DIR}/site-packages/OpenSSL/test"