aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin.juszkiewicz@linaro.org>2013-02-14 16:55:28 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-19 01:48:45 +0100
commitf72b484e53ba1c71b43ea31ef186466bef58bc43 (patch)
treee7636eff9042ff2d6d2e635dc8e45b998117d671 /meta-oe/recipes-devtools/python
parent8b7fa822757958c83949d719d59cc8bf0b94845b (diff)
downloadmeta-openembedded-contrib-f72b484e53ba1c71b43ea31ef186466bef58bc43.tar.gz
python-numpy: update to 1.7.0
Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/python')
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy/aarch64.patch41
-rw-r--r--meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb (renamed from meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb)17
2 files changed, 7 insertions, 51 deletions
diff --git a/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch b/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
deleted file mode 100644
index 8d66615649..0000000000
--- a/meta-oe/recipes-devtools/python/python-numpy/aarch64.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-From 7d7a5939dcf5821d9f381d57bfa2012568ef6b82 Mon Sep 17 00:00:00 2001
-From: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
-Date: Thu, 10 Jan 2013 21:49:01 +0100
-Subject: [PATCH] Added support for AArch64 architecture
-
-Signed-off-by: Marcin Juszkiewicz <marcin.juszkiewicz@linaro.org>
-
-Upstream-Status: backport
----
- numpy/core/include/numpy/npy_cpu.h | 2 ++
- numpy/core/include/numpy/npy_endian.h | 1 +
- 2 files changed, 3 insertions(+)
-
-diff --git a/numpy/core/include/numpy/npy_cpu.h b/numpy/core/include/numpy/npy_cpu.h
-index 8a29788..9707a7a 100644
---- a/numpy/core/include/numpy/npy_cpu.h
-+++ b/numpy/core/include/numpy/npy_cpu.h
-@@ -66,6 +66,8 @@
- #define NPY_CPU_MIPSEL
- #elif defined(__MIPSEB__)
- #define NPY_CPU_MIPSEB
-+#elif defined(__aarch64__)
-+ #define NPY_CPU_AARCH64
- #else
- #error Unknown CPU, please report this to numpy maintainers with \
- information about your platform (OS, CPU and compiler)
-diff --git a/numpy/core/include/numpy/npy_endian.h b/numpy/core/include/numpy/npy_endian.h
-index aa5ed8b..4e3349f 100644
---- a/numpy/core/include/numpy/npy_endian.h
-+++ b/numpy/core/include/numpy/npy_endian.h
-@@ -25,6 +25,7 @@
- || defined(NPY_CPU_IA64) \
- || defined(NPY_CPU_ALPHA) \
- || defined(NPY_CPU_ARMEL) \
-+ || defined(NPY_CPU_AARCH64) \
- || defined(NPY_CPU_SH_LE) \
- || defined(NPY_CPU_MIPSEL)
- #define NPY_BYTE_ORDER NPY_LITTLE_ENDIAN
---
-1.8.0
-
diff --git a/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
index 2e4bd6ad24..bbe4e63b95 100644
--- a/meta-oe/recipes-devtools/python/python-numpy_1.7.0rc1.bb
+++ b/meta-oe/recipes-devtools/python/python-numpy_1.7.0.bb
@@ -2,14 +2,10 @@ DESCRIPTION = "A sophisticated Numeric Processing Package for Python"
SECTION = "devel/python"
LICENSE = "PSF"
LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=f87832d854acbade6e9f5c601c8b30b1"
-PR = "r0"
-PV = "1.6.99+1.7.0rc1"
-REALPV = "1.7.0rc1"
-SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${REALPV}.tar.gz \
- ${CONFIGFILESURI} \
- file://aarch64.patch \
- "
+SRC_URI = "${SOURCEFORGE_MIRROR}/numpy/numpy-${PV}.tar.gz \
+ ${CONFIGFILESURI} "
+
CONFIGFILESURI ?= ""
CONFIGFILESURI_aarch64 = "file://config.h \
@@ -22,7 +18,7 @@ CONFIGFILESURI_mipsel = "file://config.h \
file://numpyconfig.h \
"
-S = "${WORKDIR}/numpy-${REALPV}"
+S = "${WORKDIR}/numpy-${PV}"
inherit distutils
@@ -36,8 +32,9 @@ do_compile_prepend() {
}
FILES_${PN}-staticdev += "${PYTHON_SITEPACKAGES_DIR}/numpy/core/lib/*.a"
-SRC_URI[md5sum] = "a4719f5a1853bc0f8892a5956d5c4229"
-SRC_URI[sha256sum] = "45ea23622f72d86bc3614446d668ee962c0475ee7b91a93ef85a5e0493962de5"
+
+SRC_URI[md5sum] = "4fa54e40b6a243416f0248123b6ec332"
+SRC_URI[sha256sum] = "f4fa70b7edbab65ee6432eb63743f5489f1919c614632b20b2fb45aa7e682ac6"
# install what is needed for numpy.test()
RDEPENDS_${PN} = "python-unittest \