aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/yajl
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-12-20 22:07:24 -0800
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:54 +0100
commitb941fd2954ff3f6f1af38bac453ab938c1344940 (patch)
tree01037a97998feea17e762ce382a77df818f93194 /meta-oe/recipes-devtools/yajl
parent72932540dc1ab8e6fcfce9130044baa3ee2d9f05 (diff)
downloadmeta-openembedded-contrib-b941fd2954ff3f6f1af38bac453ab938c1344940.tar.gz
yajl_1.0.12: Add recipe for yajl1
yajl1 and yajl2 are not ABI compatible, therefore add a recipe for latest release of yajl1 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools/yajl')
-rw-r--r--meta-oe/recipes-devtools/yajl/yajl_1.0.12.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/yajl/yajl_1.0.12.bb b/meta-oe/recipes-devtools/yajl/yajl_1.0.12.bb
new file mode 100644
index 0000000000..8ced7b84f4
--- /dev/null
+++ b/meta-oe/recipes-devtools/yajl/yajl_1.0.12.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Yet Another JSON Library."
+
+DESCRIPTION = "YAJL is a small event-driven (SAX-style) JSON parser \
+written in ANSI C, and a small validating JSON generator."
+
+HOMEPAGE = "http://lloyd.github.com/yajl/"
+
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://COPYING;md5=da2e9aa80962d54e7c726f232a2bd1e8"
+
+# Use 1.0.12 tag
+SRCREV = "17b1790fb9c8abbb3c0f7e083864a6a014191d56"
+SRC_URI = "git://github.com/lloyd/yajl;nobranch=1"
+
+inherit cmake lib_package
+
+S = "${WORKDIR}/git"
+
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"