aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorMing Liu <peter.x.liu@external.atlascopco.com>2017-05-16 13:23:18 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-05-23 15:59:14 +0200
commitacbbd49577d049bf049a5c27e75777cdc2ad3c66 (patch)
tree5d0ad6e6383aa1734a8d100f95713f37b8abbdd7 /meta-oe/recipes-devtools
parente231deaa5aacc88a8862e95037ce39d6e49a7220 (diff)
downloadmeta-openembedded-contrib-acbbd49577d049bf049a5c27e75777cdc2ad3c66.tar.gz
xerces-c: fix a wrong PACKAGECONFIG option
In xerces-c's configure, these options is being referred as follows: ...... curl_flags="-I$with_curl/include" curl_libs="-L$with_curl/lib -lcurl" icu_flags="-I$with_icu/include" icu_libs="-L$with_icu/lib -licuuc -licudata" ...... so they shouldn't be set to ${STAGING_DIR}, use ${STAGING_DIR_TARGET}${prefix} instead. Signed-off-by: Ming Liu <peter.x.liu@external.atlascopco.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
index b848b0693e..64ac74723a 100644
--- a/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
+++ b/meta-oe/recipes-devtools/xerces-c/xerces-c_3.1.4.bb
@@ -16,8 +16,8 @@ SRC_URI[sha256sum] = "9408f12c1628ecf80730bedbe8b2caad810edd01bb4c66f77b60c873e8
inherit autotools
PACKAGECONFIG ??= "curl icu"
-PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR},--with-curl=no,curl"
-PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR},--with-icu=no,icu"
+PACKAGECONFIG[curl] = "--with-curl=${STAGING_DIR_TARGET}${prefix},--with-curl=no,curl"
+PACKAGECONFIG[icu] = "--with-icu=${STAGING_DIR_TARGET}${prefix},--with-icu=no,icu"
do_install_prepend () {
sed -i -e 's:-L${STAGING_DIR}/lib:-L\$\{libdir\}:g' ${B}/xerces-c.pc