aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorDaniel Hilst Selli <danielhilst@gmail.com>2016-12-17 19:53:23 -0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-26 08:24:53 +0100
commit0df6263bf65ee632d2edf22e7ee69362e0518275 (patch)
treecda41575e901b6f55d1590f0e1f161027bb92436 /meta-oe/recipes-devtools
parentd0a8298f52f3556a988ec68ac207191c145cae76 (diff)
downloadmeta-openembedded-contrib-0df6263bf65ee632d2edf22e7ee69362e0518275.tar.gz
cxxtest: Add CxxTest framework to recipe-devtools.
>From cxxtest.org/guide.html: CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit. CxxTest is easy to use because it does not require precompiling a CxxTest testing library, it employs no advanced features of C++ (e.g. RTTI) and it supports a very flexible form of test discovery. Signed-off-by: Daniel Hilst SellI <danielhilst@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb b/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb
new file mode 100644
index 0000000000..2915011731
--- /dev/null
+++ b/meta-oe/recipes-devtools/cxxtest/cxxtest_4.3.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "CxxTest is a unit testing framework for C++ that is similar in spirit to JUnit, CppUnit, and xUnit."
+HOMEPAGE = "http://cxxtest.com/"
+LICENSE = "LGPL-2.0"
+SECTION = "devel"
+
+SRC_URI = "http://downloads.sourceforge.net/project/cxxtest/cxxtest/${PV}/cxxtest-${PV}.tar.gz"
+SRC_URI[md5sum] = "b3a24b3e1aad9acf6adac37f4c3f83ec"
+SRC_URI[sha256sum] = "356d0f4810e8eb5c344147a0cca50fc0d84122c286e7644b61cb365c2ee22083"
+LIC_FILES_CHKSUM = "file://${WORKDIR}/cxxtest-${PV}/COPYING;md5=e6a600fd5e1d9cbde2d983680233ad02"
+S = "${WORKDIR}/cxxtest-${PV}/python"
+
+inherit distutils
+
+do_install_append() {
+ install -d ${D}${includedir}
+ cp -a ../cxxtest ${D}${includedir}
+ sed '1c\
+#!/usr/bin/env python' -i ${D}${bindir}/cxxtestgen
+}
+
+BBCLASSEXTEND = "native nativesdk"