aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-08-15 15:58:55 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:04:13 +0200
commit3cf117715fa3c007c77a3603d702c808d36ce852 (patch)
tree563f98e81fee697bc526ca40b32623344d389e70 /meta-oe/recipes-devtools
parentc3dc3b630915b971996e3e496e2d991a1c132048 (diff)
downloadmeta-openembedded-contrib-3cf117715fa3c007c77a3603d702c808d36ce852.tar.gz
php: disable this version by default
There are many unaddressed CVEs which are fixed in 7.1.7 and later versions. Allow the user to define php_5.6.26 to enable building the recipe. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/php/php_5.6.26.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/php/php_5.6.26.bb b/meta-oe/recipes-devtools/php/php_5.6.26.bb
index dfce949f92..7e566b1ba2 100644
--- a/meta-oe/recipes-devtools/php/php_5.6.26.bb
+++ b/meta-oe/recipes-devtools/php/php_5.6.26.bb
@@ -8,3 +8,12 @@ SRC_URI += "file://change-AC_TRY_RUN-to-AC_TRY_LINK.patch \
"
SRC_URI[md5sum] = "cb424b705cfb715fc04f499f8a8cf52e"
SRC_URI[sha256sum] = "d47aab8083a4284b905777e1b45dd7735adc53be827b29f896684750ac8b6236"
+
+python () {
+ ver = d.getVar('PV')
+ if not d.getVar('php_'+ver+'_OK'):
+ msg = "%s disables itself because of many outstanding CVEs!" % (ver)
+ msg = msg + " Define php_%s_OK = '1' to build it." % (ver)
+ raise bb.parse.SkipPackage(msg)
+}
+