aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2016-11-23 14:13:39 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:18 +0100
commit533826b7652a2cf86ca7b665c25b98c89afc266e (patch)
tree95a8341dd6b9f8864c2617086c97f7e1fbb6d615 /meta-oe/recipes-devtools
parentfc2fc9097b2fa437d4af0338e418692b4dd6c989 (diff)
downloadmeta-openembedded-contrib-533826b7652a2cf86ca7b665c25b98c89afc266e.tar.gz
meta-oe: add explicit dependencies on gnome-common
gnome-common is deprecated and gnomebase.bbclass will soon stop depending on it, so add gnome-common to DEPENDS for the recipes that still use it. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb3
1 files changed, 1 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
index 77416d45bf..e490ae50b7 100644
--- a/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
+++ b/meta-oe/recipes-devtools/python/python-pygobject_3.20.1.bb
@@ -8,7 +8,7 @@ inherit autotools pkgconfig gnomebase distutils-base gobject-introspection
PYTHON_BASEVERSION = "2.7"
PYTHON_PN = "python"
-DEPENDS += "python glib-2.0"
+DEPENDS += "gnome-common-native python glib-2.0"
SRCNAME="pygobject"
SRC_URI = " \
@@ -31,4 +31,3 @@ do_install_append() {
# Remove files that clash with python3-pygobject; their content is same
rm ${D}${includedir}/pygobject-3.0/pygobject.h ${D}${libdir}/pkgconfig/pygobject-3.0.pc
}
-