aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJoshua Lock <joshua.g.lock@intel.com>2016-11-25 15:28:52 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-12-02 09:16:17 +0100
commitefd3696e70a6603f1a45faa4a172433514f0a487 (patch)
treeb72751ba93b050391db05a8e1be7506836b6d515 /meta-oe/recipes-devtools
parent761639b9d7681c81dd69eaf3a37c32791d6e97fd (diff)
downloadmeta-openembedded-contrib-efd3696e70a6603f1a45faa4a172433514f0a487.tar.gz
remove True option to getVar calls
getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb2
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_4.6.1.bb2
-rw-r--r--meta-oe/recipes-devtools/tcltk/tk_8.6.6.bb2
-rw-r--r--meta-oe/recipes-devtools/yajl/yajl_2.1.0.bb2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb b/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb
index 781287a909..ff7944fcdf 100644
--- a/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb
+++ b/meta-oe/recipes-devtools/geany/geany-plugins_1.28.bb
@@ -5,7 +5,7 @@ LICENSE_DEFAULT = "GPLv2"
LICENSE = "${LICENSE_DEFAULT} & BSD-2-Clause & GPLv3"
python () {
- for plugin in d.getVar('PLUGINS', True).split():
+ for plugin in d.getVar('PLUGINS').split():
if 'LICENSE_%s' % plugin not in d:
d.setVar('LICENSE_' + plugin, '${LICENSE_DEFAULT}')
}
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_4.6.1.bb b/meta-oe/recipes-devtools/nodejs/nodejs_4.6.1.bb
index 03e9812492..574d50a05b 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_4.6.1.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_4.6.1.bb
@@ -44,7 +44,7 @@ do_configure () {
GYP_DEFINES="${GYP_DEFINES}" export GYP_DEFINES
# $TARGET_ARCH settings don't match --dest-cpu settings
./configure --prefix=${prefix} --without-snapshot --shared-openssl --shared-zlib \
- --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH', True), d)}" \
+ --dest-cpu="${@map_nodejs_arch(d.getVar('TARGET_ARCH'), d)}" \
--dest-os=linux \
${ARCHFLAGS}
}
diff --git a/meta-oe/recipes-devtools/tcltk/tk_8.6.6.bb b/meta-oe/recipes-devtools/tcltk/tk_8.6.6.bb
index 59075bc6b2..d3bf397b48 100644
--- a/meta-oe/recipes-devtools/tcltk/tk_8.6.6.bb
+++ b/meta-oe/recipes-devtools/tcltk/tk_8.6.6.bb
@@ -32,7 +32,7 @@ SRC_URI[sha256sum] = "d62c371a71b4744ed830e3c21d27968c31dba74dd2c45f36b9b071e6d8
S = "${WORKDIR}/${BPN}${PV}/unix"
# Short version format: "8.6"
-VER = "${@os.path.splitext(d.getVar('PV', True))[0]}"
+VER = "${@os.path.splitext(d.getVar('PV'))[0]}"
LDFLAGS += "-Wl,-rpath,${libdir}/tcltk/${PV}/lib"
inherit autotools distro_features_check
diff --git a/meta-oe/recipes-devtools/yajl/yajl_2.1.0.bb b/meta-oe/recipes-devtools/yajl/yajl_2.1.0.bb
index 1bf538955e..d9a5821cbb 100644
--- a/meta-oe/recipes-devtools/yajl/yajl_2.1.0.bb
+++ b/meta-oe/recipes-devtools/yajl/yajl_2.1.0.bb
@@ -15,4 +15,4 @@ S = "${WORKDIR}/git"
inherit cmake lib_package
-EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib', True).replace('lib', '')}"
+EXTRA_OECMAKE = "-DLIB_SUFFIX=${@d.getVar('baselib').replace('lib', '')}"