aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2019-12-26 21:13:00 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-27 11:10:01 -0800
commit4910a848cedf7e168a5f074c499070a1f393d666 (patch)
tree360d3716486d5520c10386b5082bb3c95394eca4 /meta-oe/recipes-devtools
parentebd8eb627338c3421cc03d72e516b7e400adc581 (diff)
downloadmeta-openembedded-contrib-4910a848cedf7e168a5f074c499070a1f393d666.tar.gz
flatbuffers: add PIC compiler flag required for aarch64
Add PIC flag to CXXFLAGS in order to solve the issue with linking against the library for aarch64. Without PIC enabled, linking against this library fails with following messages: relocation R_AARCH64_ADR_PREL_PG_HI21 against symbol `[snap]' which may bind externally can not be used when making a shared object; recompile with -fPIC Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
index bd6dcef4e3..529441de10 100644
--- a/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
+++ b/meta-oe/recipes-devtools/flatbuffers/flatbuffers_1.11.0.bb
@@ -17,8 +17,8 @@ SRC_URI = "git://github.com/google/flatbuffers.git \
"
# Make sure C++11 is used, required for example for GCC 4.9
-CXXFLAGS += "-std=c++11"
-BUILD_CXXFLAGS += "-std=c++11"
+CXXFLAGS += "-std=c++11 -fPIC"
+BUILD_CXXFLAGS += "-std=c++11 -fPIC"
# BUILD_TYPE=Release is required, otherwise flatc is not installed
EXTRA_OECMAKE += "\