aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJackie Huang <jackie.huang@windriver.com>2017-09-01 15:43:29 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-09-07 10:57:37 +0200
commita002051b5e56fa4bdfcdc1544fb9658436688d67 (patch)
tree80970f277b4a7012e36d3ac24e270dc453d2d5da /meta-oe/recipes-devtools
parent719270845019134c90e8f791eaab50577ea9ab98 (diff)
downloadmeta-openembedded-contrib-a002051b5e56fa4bdfcdc1544fb9658436688d67.tar.gz
pmtools: use update-alternatives for acpixtract
acpixtract is both provided by acpica and pmtools, so use update-alternatives to fix conflicts: | file /usr/bin/acpixtract conflicts between attempted installs of pmtools-20130209+git0+3ebe0e54c5-r0.i586 and acpica-20170303-r0.i586 Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/pmtools/pmtools_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
index 94fc736b57..8491fc904d 100644
--- a/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
+++ b/meta-oe/recipes-devtools/pmtools/pmtools_git.bb
@@ -15,6 +15,11 @@ COMPATIBLE_HOST = "(i.86|x86_64).*-linux"
S = "${WORKDIR}/git"
+inherit update-alternatives
+
+ALTERNATIVE_PRIORITY = "90"
+ALTERNATIVE_${PN} = "acpixtract"
+
do_configure[noexec] = "1"
do_compile() {
oe_runmake