aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorJonathan Liu <net147@gmail.com>2017-10-12 18:25:44 +1100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-10-17 10:32:03 +0000
commitaf0d0f893914f84adb8f13e30ea5ac5dd625442c (patch)
treebb77cf1ce9112a36c45c901eae69fc308a76f051 /meta-oe/recipes-devtools
parent18bb0929e1832163f536bc0fd54d59ea7b66b32b (diff)
downloadmeta-openembedded-contrib-af0d0f893914f84adb8f13e30ea5ac5dd625442c.tar.gz
nodejs: Add npx to nodejs-npm package
${bindir}/npx is a symbolic link to npm-cli.js in the npm module. This avoids the nodejs package depending on nodejs-npm. Signed-off-by: Jonathan Liu <net147@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_8.4.0.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_8.4.0.bb b/meta-oe/recipes-devtools/nodejs/nodejs_8.4.0.bb
index 5c580fb72c..5bcbc0007d 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_8.4.0.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_8.4.0.bb
@@ -79,7 +79,7 @@ do_install_append_class-target() {
}
PACKAGES =+ "${PN}-npm"
-FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm"
+FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm ${bindir}/npx"
RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
PACKAGES =+ "${PN}-systemtap"