aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
authorYi Zhao <yi.zhao@windriver.com>2015-06-04 15:48:12 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-06-08 14:15:24 +0200
commit74f96955feca2301227b07e585fd47d26aab5e70 (patch)
tree78324eaddd1090a433e384ac35414760b33b1117 /meta-oe/recipes-devtools
parent44791c221c7542d0c2301cd849afb188859f25e9 (diff)
downloadmeta-openembedded-contrib-74f96955feca2301227b07e585fd47d26aab5e70.tar.gz
nodejs: fix build failure for multilib
bitbake nodejs [snip] sed: can't read /buildarea2/build/tmp/work/core2-64-poky-linux/nodejs/0.12.4-r0/image/usr/lib64/node_modules/npm/bin/npm-cli.js: No such file or directory [snip] The node modules are not binary files. It doesn't make sense to install them to /usr/lib64. Use /usr/lib/node_modules instead of /usr/lib64/node_modules even on multilib. Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb9
1 files changed, 3 insertions, 6 deletions
diff --git a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
index 4e1ba1f729..81b8c0d238 100644
--- a/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
+++ b/meta-oe/recipes-devtools/nodejs/nodejs_0.12.4.bb
@@ -61,20 +61,17 @@ do_install_append_class-native() {
# /usr/bin/npm is symlink to /usr/lib/node_modules/npm/bin/npm-cli.js
# use sed on npm-cli.js because otherwise symlink is replaced with normal file and
# npm-cli.js continues to use old shebang
- sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js
+ sed "1s^.*^#\!/usr/bin/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
}
do_install_append_class-target() {
- sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${libdir}/node_modules/npm/bin/npm-cli.js
+ sed "1s^.*^#\!${bindir}/env node^g" -i ${D}${exec_prefix}/lib/node_modules/npm/bin/npm-cli.js
}
PACKAGES =+ "${PN}-npm"
-FILES_${PN}-npm = "${libdir}/node_modules ${bindir}/npm"
+FILES_${PN}-npm = "${exec_prefix}/lib/node_modules ${bindir}/npm"
RDEPENDS_${PN}-npm = "bash python-shell python-datetime python-subprocess python-textutils"
-PACKAGES =+ "${PN}-dtrace"
-FILES_${PN}-dtrace = "${libdir}/dtrace"
-
PACKAGES =+ "${PN}-systemtap"
FILES_${PN}-systemtap = "${datadir}/systemtap"