aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/ostree
diff options
context:
space:
mode:
authorAlex Kiernan <alex.kiernan@gmail.com>2019-12-16 02:53:07 +0000
committerKhem Raj <raj.khem@gmail.com>2019-12-16 08:38:35 -0800
commit96d881d545e5a5de0f2fb057ef7dc19a2ff02320 (patch)
treed725aa568dd75f363380aa054cd133ba0e3ab4b0 /meta-oe/recipes-extended/ostree
parentd06a5b3f080bc58d3a67eb5b02d5aad17999bd82 (diff)
downloadmeta-openembedded-contrib-96d881d545e5a5de0f2fb057ef7dc19a2ff02320.tar.gz
ostree: Add support for gjs tests
Now gjs is packaged in meta-gnome, add support for gjs tests through PACKAGECONFIG; note gjs has a large dependency footprint, requiring (at least) gobject-instrospection-data, gtk-3 and x11. Move python3-pyyaml to RDEPENDS directly based on the layer, so that building ptest without meta-python is possible (though more tests will have to be skipped). Signed-off-by: Alex Kiernan <alex.kiernan@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/ostree')
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2019.6.bb10
1 files changed, 3 insertions, 7 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2019.6.bb b/meta-oe/recipes-extended/ostree/ostree_2019.6.bb
index 86a7aac31c..a40cc52757 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2019.6.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2019.6.bb
@@ -56,6 +56,7 @@ PACKAGECONFIG[avahi] = "--with-avahi, --without-avahi, avahi"
PACKAGECONFIG[builtin-grub2-mkconfig] = "--with-builtin-grub2-mkconfig, --without-builtin-grub2-mkconfig"
PACKAGECONFIG[curl] = "--with-curl, --without-curl, curl"
PACKAGECONFIG[dracut] = "--with-dracut, --without-dracut"
+PACKAGECONFIG[gjs] = "ac_cv_path_GJS=${bindir}/gjs"
PACKAGECONFIG[gnutls] = "--with-crypto=gnutls, , gnutls"
PACKAGECONFIG[libarchive] = "--with-libarchive, --without-libarchive, libarchive"
PACKAGECONFIG[libmount] = "--with-libmount, --without-libmount, util-linux"
@@ -166,9 +167,10 @@ RDEPENDS_${PN}-ptest += " \
grep \
python3-core \
python3-multiprocessing \
- python3-pyyaml \
tar \
${PN}-trivial-httpd \
+ ${@bb.utils.contains('BBFILE_COLLECTIONS', 'meta-python', 'python3-pyyaml', '', d)} \
+ ${@bb.utils.contains('PACKAGECONFIG', 'gjs', 'gjs', '', d)} \
"
RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils glibc-localedata-en-us"
@@ -179,9 +181,3 @@ SYSTEMD_SERVICE_${PN} = "ostree-remount.service ostree-finalize-staged.path"
SYSTEMD_SERVICE_${PN}-switchroot = "ostree-prepare-root.service"
BBCLASSEXTEND = "native"
-
-python __anonymous() {
- if bb.utils.contains('PTEST_ENABLED', '1', 'True', '', d):
- if not bb.utils.contains_any('BBFILE_COLLECTIONS', 'meta-python', 'True', '', d):
- raise bb.parse.SkipRecipe('ptest requires meta-python to be present.')
-}