aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/pmdk
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-extended/pmdk
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/pmdk')
-rw-r--r--meta-oe/recipes-extended/pmdk/pmdk_1.9.bb18
1 files changed, 9 insertions, 9 deletions
diff --git a/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb b/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb
index 8bb89f418c..4325c15c33 100644
--- a/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb
+++ b/meta-oe/recipes-extended/pmdk/pmdk_1.9.bb
@@ -7,7 +7,7 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=b44ee63f162f9cdb18fff1224877aafd"
DEPENDS = "ndctl"
# Required to have the fts.h header for musl
-DEPENDS_append_libc-musl = " fts"
+DEPENDS:append:libc-musl = " fts"
S = "${WORKDIR}/git"
@@ -25,9 +25,9 @@ inherit autotools-brokensep pkgconfig
EXTRA_OEMAKE = "BUILD_EXAMPLES='n' DOC='n' HOST_SYS='${HOST_SYS}' EXTRA_CFLAGS='${SELECTED_OPTIMIZATION}' LIB_PREFIX=${baselib}"
# Fix the missing fts libs when using musl
-EXTRA_OEMAKE_append_libc-musl = " EXTRA_LIBS='-lfts'"
+EXTRA_OEMAKE:append:libc-musl = " EXTRA_LIBS='-lfts'"
-do_configure_prepend() {
+do_configure:prepend() {
touch .skip-doc
}
@@ -39,11 +39,11 @@ do_install() {
}
# Include these by default otherwise the SDK is not very useful
-FILES_${PN} += "${bindir}/pmempool ${bindir}/daxio"
-FILES_${PN} += "${libdir}/*so*"
-FILES_${PN} += "${libdir}/pkgconfig/*.pc"
-FILES_${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/"
-FILES_${PN} += "/usr/etc"
-FILES_${PN} += "/usr/share"
+FILES:${PN} += "${bindir}/pmempool ${bindir}/daxio"
+FILES:${PN} += "${libdir}/*so*"
+FILES:${PN} += "${libdir}/pkgconfig/*.pc"
+FILES:${PN} += "${includedir}/libpmemobj++/* ${includedir}/libpmemobj/* /usr/*/include/"
+FILES:${PN} += "/usr/etc"
+FILES:${PN} += "/usr/share"
COMPATIBLE_HOST='(x86_64).*'