aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/rarpd
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2018-06-12 18:13:44 +0000
committerArmin Kuster <akuster808@gmail.com>2018-09-04 07:33:51 -0700
commit280157bc380ff98d24ac89674e332c48802574b1 (patch)
tree5d027957071543e2f764bd7de83a14ad0ad8a6e9 /meta-oe/recipes-extended/rarpd
parentd1824f5572faa9d7cc8eb14dd83d61faa8c35988 (diff)
downloadmeta-openembedded-contrib-280157bc380ff98d24ac89674e332c48802574b1.tar.gz
rarpd, sblim-sfcb, openct: inherit systemd unconditionally
* the inherit was controlled by VIRTUAL-RUNTIME_init_manager and the installation of .service files by DISTRO_FEATURES and systemd was in DISTRO_FEATURES but not in VIRTUAL-RUNTIME_init_manager it was causing QA issues about unpackaged .service files ERROR: rarpd-ss981107-r0 do_package: QA Issue: rarpd: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/rarpd.service ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/sblim-sfcb.service ERROR: sblim-sfcb-1.4.9-r0 do_package: QA Issue: sblim-sfcb: Files/directories were installed but not shipped in any package: /lib /lib/systemd /lib/systemd/system /lib/systemd/system/sblim-sfcb.service * systemd.bbclass will take care of removing /lib/systemd when systemd isn't in DISTRO_FEATURES, so we can remove both conditions Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended/rarpd')
-rw-r--r--meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb8
1 files changed, 3 insertions, 5 deletions
diff --git a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
index 4025b8087e..7c9f2df9db 100644
--- a/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
+++ b/meta-oe/recipes-extended/rarpd/rarpd_ss981107.bb
@@ -38,13 +38,11 @@ do_install() {
install -m 644 rarpd.8 ${D}${mandir}/man8/rarpd.8
install -m 644 ${WORKDIR}/ethers.sample ${D}${sysconfdir}/ethers
- if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
- install -d ${D}${systemd_unitdir}/system
- install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
- fi
+ install -d ${D}${systemd_unitdir}/system
+ install -m 0644 ${WORKDIR}/rarpd.service ${D}${systemd_unitdir}/system/
}
-inherit ${@bb.utils.filter('VIRTUAL-RUNTIME_init_manager', 'systemd', d)}
+inherit systemd
SYSTEMD_PACKAGES = "${PN}"
SYSTEMD_SERVICE_${PN} = "rarpd.service"