aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-08-18 11:05:27 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:01 +0200
commit32a93e0d5ae34af3e36ef1e3bad2b330ad19a5c0 (patch)
treef108ef2892a4978f4d3c7a1d5c3ad89b39f5832d /meta-oe/recipes-extended
parente41be4b46198a5ca30487fd021a52f5849d91f95 (diff)
downloadmeta-openembedded-contrib-32a93e0d5ae34af3e36ef1e3bad2b330ad19a5c0.tar.gz
rsyslog: install logrotate configuration file into correct location
Previously we used update-alternatives to manage this configuration file, creating link under /etc/logrotate.d/ directory. However, we later dropped the update-alternatives approach and explicitly setting rsyslog to conflict with other syslog providers. So we need to install the logrotate configuration file under /etc/logrotate.d to make things right. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
index 6e3a75c284..bd317be645 100644
--- a/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
+++ b/meta-oe/recipes-extended/rsyslog/rsyslog_8.22.0.bb
@@ -119,9 +119,10 @@ do_install_ptest() {
do_install_append() {
install -d "${D}${sysconfdir}/init.d"
+ install -d "${D}${sysconfdir}/logrotate.d"
install -m 755 ${WORKDIR}/initscript ${D}${sysconfdir}/init.d/syslog
install -m 644 ${WORKDIR}/rsyslog.conf ${D}${sysconfdir}/rsyslog.conf
- install -m 644 ${WORKDIR}/rsyslog.logrotate ${D}${sysconfdir}/logrotate.rsyslog
+ install -m 644 ${WORKDIR}/rsyslog.logrotate ${D}${sysconfdir}/logrotate.d/logrotate.rsyslog
}
FILES_${PN} += "${bindir}"