aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-30 05:59:48 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:43:21 +0200
commit83dfe144915876f74e8cba0f7f11ab5143bfbd76 (patch)
tree3d08a033af295372526b73ced78e39a31b192104 /meta-oe/recipes-extended
parent49bb63d5b35b3e156a66727ebb0e696ef8d4fec5 (diff)
downloadmeta-openembedded-contrib-83dfe144915876f74e8cba0f7f11ab5143bfbd76.tar.gz
fluentbit: Fix parallel build race
Sometimes with high parallism the build fails like below | In file included from /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_thread_libco.h:24:0, | from /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_thread.h:41, | from /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_io.h:26, | from /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_output.h:34, | from /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_plugin_proxy.h:25, | from /mnt/a/oe/workspace/sources/fluentbit/src/proxy/go/go.c:22: | /mnt/a/oe/workspace/sources/fluentbit/include/fluent-bit/flb_mem.h:31:10: fatal error: jemalloc/jemalloc.h: No such file or directory | #include <jemalloc/jemalloc.h> | ^~~~~~~~~~~~~~~~~~~~~ Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch24
-rw-r--r--meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb3
2 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch
new file mode 100644
index 0000000000..90242aeb64
--- /dev/null
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit/0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch
@@ -0,0 +1,24 @@
+From 84d70b6bc744cd348e66a0bc6c7958cdfa9ce670 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 29 Jun 2017 12:56:21 -0700
+Subject: [PATCH] flb-plugin-proxy-go: Add missing dependency on jemalloc
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ src/proxy/go/CMakeLists.txt | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/src/proxy/go/CMakeLists.txt b/src/proxy/go/CMakeLists.txt
+index 3273346..02a54c2 100644
+--- a/src/proxy/go/CMakeLists.txt
++++ b/src/proxy/go/CMakeLists.txt
+@@ -2,3 +2,6 @@ set(src
+ go.c)
+
+ add_library(flb-plugin-proxy-go STATIC ${src})
++if(FLB_JEMALLOC)
++ target_link_libraries(flb-plugin-proxy-go libjemalloc)
++endif()
+--
+2.13.2
+
diff --git a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
index 46c47fd55e..83818c84d5 100644
--- a/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
+++ b/meta-oe/recipes-extended/fluentbit/fluentbit_0.11.11.bb
@@ -3,6 +3,7 @@ HOMEPAGE = "http://fluentbit.io"
BUGTRACKER = "https://github.com/fluent/fluent-bit/issues"
SRC_URI = "http://fluentbit.io/releases/0.11/fluent-bit-${PV}.tar.gz \
+ file://0001-flb-plugin-proxy-go-Add-missing-dependency-on-jemall.patch \
file://0002-msgpack-Add-comment-for-intended-fallthrough.patch \
"
SRC_URI[md5sum] = "7bce8091c41fb6412b7fe0185b3cb8d6"
@@ -21,3 +22,5 @@ inherit cmake systemd
EXTRA_OECMAKE = "-DGNU_HOST=${HOST_SYS} -DFLB_ALL=ON -DFLB_TD=1"
SYSTEMD_SERVICE_${PN} = "fluent-bit.service"
+
+TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}"