aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2013-03-05 05:26:37 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2013-03-13 17:21:52 +0100
commita214c903e4037fad32abdee704b6f913f1f7d629 (patch)
treedfc7571589ca8735853cf983cc1398a5bf939f92 /meta-oe/recipes-extended
parent0a7d88ea219ec5e8a966aaafe08662d288e6e760 (diff)
downloadmeta-openembedded-contrib-a214c903e4037fad32abdee704b6f913f1f7d629.tar.gz
tcsh: Upgrade tcsh_6.17.02.bb -> tcsh_6.18.01.bb
Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/tcsh/files/07_nls.patch14
-rw-r--r--meta-oe/recipes-extended/tcsh/files/cross-compile.patch12
-rw-r--r--meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch27
-rw-r--r--meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch18
-rw-r--r--meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb (renamed from meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb)16
5 files changed, 16 insertions, 71 deletions
diff --git a/meta-oe/recipes-extended/tcsh/files/07_nls.patch b/meta-oe/recipes-extended/tcsh/files/07_nls.patch
deleted file mode 100644
index fe7845f43e..0000000000
--- a/meta-oe/recipes-extended/tcsh/files/07_nls.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Author: Franz Pletz <fpletz@franz-pletz.org>
-Description: Fixes NLS build bug
-
---- a/nls/Makefile.in
-+++ b/nls/Makefile.in
-@@ -2,7 +2,7 @@
-
- LOCALES= C et finnish french german greek italian ja pl russian \
- spanish ukrainian
--GENCAT= gencat
-+GENCAT= gencat --new
- INSTALL= ginstall
-
- datarootdir=@datarootdir@
diff --git a/meta-oe/recipes-extended/tcsh/files/cross-compile.patch b/meta-oe/recipes-extended/tcsh/files/cross-compile.patch
deleted file mode 100644
index 06dcfdae03..0000000000
--- a/meta-oe/recipes-extended/tcsh/files/cross-compile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -git a/Makefile.in b/Makefile.in
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -446,7 +446,7 @@
-
- gethost: gethost.c sh.err.h tc.const.h sh.h
- rm -f gethost
-- ${CC} -o gethost ${LDFLAGS} ${CFLAGS} ${CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
-+ ${BUILD_CC} -o gethost ${BUILD_LDFLAGS} ${BUILD_CFLAGS} ${BUILD_CPPFLAGS} ${DFLAGS} $(srcdir)/gethost.c ${LIBES} ${EXTRALIBS}
-
- tc.defs.c: gethost host.defs
- @rm -f $@.tmp
diff --git a/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch b/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch
deleted file mode 100644
index 43001f117d..0000000000
--- a/meta-oe/recipes-extended/tcsh/files/fix-make-catalogs.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-Author: christos <christos>
-Date: Thu May 13 18:39:02 2010 +0000
-
- add a rule to make catalogs and propagate ${MAKE} instead of hard-coding make.
-
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -687,7 +687,7 @@ shar:
- rm -rf tcsh-${VERSION}
-
- catalogs:
-- @(cd nls; make catalogs)
-+ @(cd nls; ${MAKE})
-
- tcsh-${VERSION}.tar.Z:
- rm -rf tcsh-${VERSION}
---- a/nls/Makefile.in
-+++ b/nls/Makefile.in
-@@ -18,7 +18,7 @@ install: $(INSTALLED)
- $(INSTALL) $< $@
-
- %.cat:
-- $(GENCAT) $@ $(@:%.cat=%)/*set*
-+ cat $(@:%.cat=%)/charset $(@:%.cat=%)/set* | $(GENCAT) $@
-
- clean:
- $(RM) $(CATALOGS)
diff --git a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
index 7f3e926247..3dd420a0e3 100644
--- a/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
+++ b/meta-oe/recipes-extended/tcsh/files/tcsh-6.17.02-multibyte.patch
@@ -1,16 +1,18 @@
Author: Jean-Luc Leger <reiga@dspnet.fr.eu.org>
Description: fix broken globbing expansion
Debian-Bug: #603545
---- a/tc.str.c
-+++ b/tc.str.c
-@@ -104,8 +104,9 @@ rt_mbtowc(Char *pwc, const char *s, size_t n)
-
- memset (&mb, 0, sizeof mb);
- ret = mbrtowc(&tmp, s, n, &mb);
+Index: tcsh-6.18.01/tc.str.c
+===================================================================
+--- tcsh-6.18.01.orig/tc.str.c 2012-01-10 13:34:31.000000000 -0800
++++ tcsh-6.18.01/tc.str.c 2013-02-26 13:12:13.429153489 -0800
+@@ -122,8 +122,9 @@
+ #else
+ ret = mbtowc(&tmp, s, n);
+ #endif
- if (ret > 0) {
+ if (ret >= 0)
*pwc = tmp;
-+ if (ret > 0) {
- #ifdef UTF16_STRINGS
++ if (ret >= 0) {
+ #if defined(UTF16_STRINGS) && defined(HAVE_MBRTOWC)
if (tmp >= 0xd800 && tmp <= 0xdbff) {
/* UTF-16 surrogate pair. Fetch second half and compute
diff --git a/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
index c4c78f4787..d85fba841a 100644
--- a/meta-oe/recipes-extended/tcsh/tcsh_6.17.02.bb
+++ b/meta-oe/recipes-extended/tcsh/tcsh_6.18.01.bb
@@ -9,22 +9,23 @@ LIC_FILES_CHKSUM = "file://Copyright;md5=1cf29be62df2be1a3763118b25b4c780"
SECTION = "base"
SRC_URI = " \
- ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02.orig.tar.gz;name=tarball \
- ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_6.17.02-4.diff.gz;name=diffs \
+ ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}.orig.tar.gz;name=tarball \
+ ${DEBIAN_MIRROR}/main/t/tcsh/tcsh_${PV}-2.diff.gz;name=diffs \
file://01_build.1.patch \
file://01_build.2.patch \
file://01_build.3.patch \
- file://07_nls.patch \
file://15_no-strip.patch \
file://disable-test-notty.patch \
file://disable-test-nice.patch \
- file://fix-make-catalogs.patch \
file://disable-lexical.at-31.patch \
file://12_unknown_lscolors.patch \
file://tcsh-6.17.02-multibyte.patch \
file://disable-broken-test.patch \
- file://cross-compile.patch \
"
+SRC_URI[tarball.md5sum] = "6eed09dbd4223ab5b6955378450d228a"
+SRC_URI[tarball.sha256sum] = "d81ca27851f3e8545666399b4bcf25433e602a195113b3f7c73886fef84c9fa8"
+SRC_URI[diffs.md5sum] = "ea39b818b624aca49ebf2cd2708d6ff9"
+SRC_URI[diffs.sha256sum] = "95b0c1a339b745c47c5d2f9d02c22a71597462e2e882b51614a9d1f75bd3d16c"
inherit autotools
@@ -46,8 +47,3 @@ pkg_postinst_${PN} () {
#!/bin/sh -e
echo /usr/bin/tcsh >> $D/etc/shells
}
-
-SRC_URI[tarball.md5sum] = "ad6e89ddb654972b4c2a8bad06778625"
-SRC_URI[tarball.sha256sum] = "8c675729810eb49102b68e09be4f3f592dfa0be2c238f0d0a58e5c1147da7dd8"
-SRC_URI[diffs.md5sum] = "735286c36a83a043015b30871c7ab6b6"
-SRC_URI[diffs.sha256sum] = "61c0b0f7ebbc07544551f56b66c6e78def702c2197307e960898182b340ffe67"