aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorYannick Gicquel <yannick.gicquel@iot.bzh>2016-03-31 13:55:46 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2016-04-12 11:07:44 +0200
commitc7cb15542e94d58748c005656cacee3bc921253d (patch)
treea0ad000f24503d67a9d7486d3d7410d7d559cf32 /meta-oe/recipes-extended
parent81cc98ef714ab383d8ec8063b9b74b2a012ef95a (diff)
downloadmeta-openembedded-contrib-c7cb15542e94d58748c005656cacee3bc921253d.tar.gz
p7zip: add native extend
This add a support for native build of 7za, 7z and 7zr binaries. Signed-off-by: Yannick Gicquel <yannick.gicquel@iot.bzh> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
index be706e1aca..b89fc42dea 100644
--- a/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
+++ b/meta-oe/recipes-extended/p7zip/p7zip_9.20.1.bb
@@ -15,3 +15,21 @@ do_install() {
install -d ${D}${bindir}
install -m 0755 ${S}/bin/* ${D}${bindir}
}
+
+# all3: to build bin/7za, bin/7z (with its plugins), bin/7zr and bin/7zCon.sfx
+EXTRA_OEMAKE_class-native = "all3"
+
+do_install_class-native() {
+ install -d ${D}${bindir}
+ install -d ${D}${bindir}/Codecs
+ install -m 0755 ${S}/bin/7* ${D}${bindir}
+ install -m 0755 ${S}/bin/Codecs/* ${D}${bindir}/Codecs
+
+ # Create a shell script wrapper to execute next to 7z.so
+ mv ${D}${bindir}/7z ${D}${bindir}/7z.bin
+ echo "#! /bin/sh" > ${D}${bindir}/7z
+ echo "exec ${D}${bindir}/7z.bin \"\$@\"" >> ${D}${bindir}/7z
+ chmod 0755 ${D}${bindir}/7z
+}
+
+BBCLASSEXTEND += "native"