aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMingli Yu <Mingli.Yu@windriver.com>2017-08-22 15:02:58 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2017-08-28 11:06:03 +0200
commitff017c9bedc96036b41379893546b41a1cc08b40 (patch)
treefced8647f7fa385918d3c673ab676e894e8a4c8d /meta-oe/recipes-extended
parent5630f33a1e87d0d9a1d32e8fd5e9b8cf2be54cb4 (diff)
downloadmeta-openembedded-contrib-ff017c9bedc96036b41379893546b41a1cc08b40.tar.gz
mozjs: customize HOST_CFLAGS
Customize HOST_CFLAGS, HOST_CXXFLAGS and HOST_LDFLAGS to fix do_configure error as previously use the common CFLAGS and CXXFLAGS in both cross-compile env and host env, and the option -fstack-protector-strong which not recognized in host env can result in do_configure error as below. | checking whether the host c compiler (gcc -O2 -pipe -g -fstack-protector-strong -D_FORTIFY_SOURCE=2 -Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed -fstack-protector-strong -Wl,-z,relro,-z,now) works... configure: error: installation or configuration problem: host compiler gcc cannot create executables. Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Jackie Huang <jackie.huang@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index b6744395fe..b72ee7bb3d 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -51,6 +51,9 @@ PACKAGECONFIG[x11] = "--with-x --x-includes=${STAGING_INCDIR} --x-libraries=${ST
# mozjs requires autoreconf 2.13
do_configure() {
+ export HOST_CFLAGS="${BUILD_CFLAGS}"
+ export HOST_CXXFLAGS="${BUILD_CPPFLAGS}"
+ export HOST_LDFLAGS="${BUILD_LDFLAGS}"
( cd ${S}
gnu-configize --force
mv config.guess config.sub build/autoconf )