aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2019-01-29 21:17:23 -0800
committerKhem Raj <raj.khem@gmail.com>2019-01-30 13:34:49 -0800
commitc4432a5f627de0f941dfcd563716c335352d6b71 (patch)
tree75d8a27f713e395379a6a99242e00012dc97f483 /meta-oe/recipes-extended
parentfe08cf35450f9d10e88e48fb91cb99f1a406f3b4 (diff)
downloadmeta-openembedded-contrib-c4432a5f627de0f941dfcd563716c335352d6b71.tar.gz
mozjs: Fix symbol visibility with clang/libc++
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch37
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb1
2 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch b/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch
new file mode 100644
index 0000000000..6c87ff2a4c
--- /dev/null
+++ b/meta-oe/recipes-extended/mozjs/mozjs/JS_PUBLIC_API.patch
@@ -0,0 +1,37 @@
+Patch from https://bugzilla.mozilla.org/show_bug.cgi?id=1426865
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+Upstream-Status: Submitted [https://bugzilla.mozilla.org/show_bug.cgi?id=1426865]
+--- a/js/public/TypeDecls.h
++++ b/js/public/TypeDecls.h
+@@ -21,22 +21,23 @@
+ #include <stdint.h>
+
+ #include "js-config.h"
++#include "jstypes.h"
+
+ struct JSContext;
+-class JSFunction;
++class JS_PUBLIC_API(JSFunction);
+ class JSObject;
+-class JSScript;
+-class JSString;
+-class JSAddonId;
++class JS_PUBLIC_API(JSScript);
++class JS_PUBLIC_API(JSString);
++class JS_PUBLIC_API(JSAddonId);
+
+-struct jsid;
++struct JS_PUBLIC_API(jsid);
+
+ namespace JS {
+
+ typedef unsigned char Latin1Char;
+
+-class Symbol;
+-class Value;
++class JS_PUBLIC_API(Symbol);
++class JS_PUBLIC_API(Value);
+ template <typename T> class Handle;
+ template <typename T> class MutableHandle;
+ template <typename T> class Rooted;
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
index a28ecc57d6..74dd15bfcb 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_52.9.1.bb
@@ -15,6 +15,7 @@ SRC_URI = "http://archive.ubuntu.com/ubuntu/pool/main/m/mozjs52/mozjs52_52.9.1.o
file://add-riscv-support.patch \
file://0001-mozjs-fix-coredump-caused-by-getenv.patch \
file://format-overflow.patch \
+ file://JS_PUBLIC_API.patch \
"
SRC_URI_append_libc-musl = " \
file://0006-support-musl.patch \