aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2015-03-09 15:21:14 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2015-03-21 16:42:21 +0100
commit401b0bb66235836e717d07d1593c8e59779caefc (patch)
tree7e6378116ed900e82d00c3fac2326df524129384 /meta-oe/recipes-extended
parent9b05b3eb6d036eb661911e5e660447468fe4bc9d (diff)
downloadmeta-openembedded-contrib-401b0bb66235836e717d07d1593c8e59779caefc.tar.gz
sip: Split python into a new package for runtime support.
The package is named python-sip for backwards compatibility. Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/sip/sip_4.16.4.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/sip/sip_4.16.4.bb b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
index 607ace69fa..780ccdc22f 100644
--- a/meta-oe/recipes-extended/sip/sip_4.16.4.bb
+++ b/meta-oe/recipes-extended/sip/sip_4.16.4.bb
@@ -14,6 +14,8 @@ SRC_URI[sha256sum] = "ceda443fc5e129e67a067e2cd7b73ff037f8b10b50e407baa2b1d9f219
BBCLASSEXTEND = "native"
+PACKAGES += "python-sip"
+
inherit qmake2 python-dir pythonnative distro_features_check
# depends on qt4-x11-free
REQUIRED_DISTRO_FEATURES = "x11"
@@ -47,6 +49,6 @@ do_install() {
oe_runmake install
}
-FILES_${PN} += "${libdir}/${PYTHON_DIR}/site-packages/"
+FILES_python-${PN} = "${libdir}/${PYTHON_DIR}/site-packages/"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"