aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2015-05-05 14:11:12 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2015-07-16 21:09:05 +0200
commite836f8f936f1a39e8b29c08a5979919d9e04cbde (patch)
tree884b28f2d2fe92cc41677f6176aca2e776245d17 /meta-oe/recipes-extended
parentb3b6743e0e2cc21e86e33efb06bb68881c0420b0 (diff)
downloadmeta-openembedded-contrib-e836f8f936f1a39e8b29c08a5979919d9e04cbde.tar.gz
gegl, crash, libsecret, mpg123, tinymembench, gammu, mosh, llvm3.3, breakpad, php, mozjs, libopus: disable thumb where it fails for qemuarm
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb9
1 files changed, 9 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
index 10028a0429..dc4ce9d0ac 100644
--- a/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
+++ b/meta-oe/recipes-extended/mozjs/mozjs_17.0.0.bb
@@ -62,3 +62,12 @@ addtask sourceclean before do_patch after do_unpack
PACKAGES =+ "lib${PN}"
FILES_lib${PN} += "${libdir}/lib*.so"
FILES_${PN}-dev += "${bindir}/js17-config"
+
+# Fails to build with thumb-1 (qemuarm)
+#| {standard input}: Assembler messages:
+#| {standard input}:2172: Error: shifts in CMP/MOV instructions are only supported in unified syntax -- `mov r2,r1,LSR#20'
+#| {standard input}:2173: Error: unshifted register required -- `bic r2,r2,#(1<<11)'
+#| {standard input}:2174: Error: unshifted register required -- `orr r1,r1,#(1<<20)'
+#| {standard input}:2176: Error: instruction not supported in Thumb16 mode -- `subs r2,r2,#0x300'
+#| {standard input}:2178: Error: instruction not supported in Thumb16 mode -- `subs r5,r2,#52'
+ARM_INSTRUCTION_SET = "arm"