aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2021-07-29 17:04:53 +0200
committerKhem Raj <raj.khem@gmail.com>2021-08-03 10:21:25 -0700
commitc61dc077bbd81260e4f167fa2251643ba0ba6974 (patch)
tree66c3243f8f64ae60f66f70a16e8128c247254a65 /meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
parentc5f7cfb8db54cfa4257797db5bd87828dea43296 (diff)
downloadmeta-openembedded-contrib-c61dc077bbd81260e4f167fa2251643ba0ba6974.tar.gz
Convert to new override syntax
This is the result of automated script (0.9.1) conversion: oe-core/scripts/contrib/convert-overrides.py . converting the metadata to use ":" as the override character instead of "_". Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
index 1863f95f0f..26d51bdafd 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20190801.bb
@@ -7,11 +7,11 @@ LIC_FILES_CHKSUM = " \
"
DEPENDS = "python3 glib-2.0 pango giflib tiff libxml2 jpeg libtool uthash gettext-native"
-DEPENDS_append_class-target = " libxi"
+DEPENDS:append:class-target = " libxi"
inherit autotools pkgconfig python3native features_check gettext gtk-icon-cache mime mime-xdg
-REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
+REQUIRED_DISTRO_FEATURES:append:class-target = " x11"
# tag 20190801
SRCREV = "ac635b818e38ddb8e7e2e1057330a32b4e25476e"
@@ -21,7 +21,7 @@ SRC_URI = "git://github.com/${BPN}/${BPN}.git \
S = "${WORKDIR}/git"
EXTRA_OECONF += "--without-libuninameslist --enable-python-scripting --enable-python-extension"
-EXTRA_OECONF_append_class-native = " with_x=no"
+EXTRA_OECONF:append:class-native = " with_x=no"
LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
BUILD_LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
@@ -34,14 +34,14 @@ BUILD_LDFLAGS += "-lpython${PYTHON_BASEVERSION}${PYTHON_ABI}"
PACKAGES =+ "${PN}-python"
-FILES_${PN} += " \
+FILES:${PN} += " \
${datadir}/appdata \
${datadir}/metainfo \
${datadir}/mime \
"
-FILES_${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
-RDEPENDS_${PN}-python = "python3"
+FILES:${PN}-python = "${PYTHON_SITEPACKAGES_DIR} ${datadir}/${BPN}/python"
+RDEPENDS:${PN}-python = "python3"
# for e.g kde's oxygen-fonts
BBCLASSEXTEND = "native"