aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/libsdl
diff options
context:
space:
mode:
authorWolfgang Meyer <Wolfgang.Meyer@gossenmetrawatt.com>2022-08-11 13:23:59 +0200
committerKhem Raj <raj.khem@gmail.com>2022-08-12 01:24:27 -0700
commit67b3fc7ad000e21b6f80a225cc06a8932558f617 (patch)
tree929f1b7365e0846c616144275a857a2db050b750 /meta-oe/recipes-graphics/libsdl
parent68d5d03be43f545fb8bdca8b9aae0f7f102b741b (diff)
downloadmeta-openembedded-contrib-67b3fc7ad000e21b6f80a225cc06a8932558f617.tar.gz
libsdl2-ttf: upgrade 2.0.18 -> 2.20.0
Changelog: * Added support for building with CMake * Added TTF_GetFontWrappedAlign() and TTF_SetFontWrappedAlign() to set alignment on wrapped text * Added functions to render using FreeType LCD algorithm: TTF_RenderText_LCD() TTF_RenderUTF8_LCD() TTF_RenderUNICODE_LCD() TTF_RenderText_LCD_Wrapped() TTF_RenderUTF8_LCD_Wrapped() TTF_RenderUNICODE_LCD_Wrapped() TTF_RenderGlyph_LCD() TTF_RenderGlyph32_LCD() * Added TTF_SetFontDirection() and TTF_SetFontScriptName() for additional control over fonts using HarfBuzz * Updated to FreeType version 2.12.1 and HarfBuzz version 2.9.1, fixing CVE-2018-25032 * Fixed crash when loading fonts at certain sizes on Windows * Fix memory corruption loading malformed TTF files (CVE-2022-27470) Signed-off-by: Wolfgang Meyer <Wolfgang.Meyer@gossenmetrawatt.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/libsdl')
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.18.bb27
-rw-r--r--meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.20.0.bb32
2 files changed, 32 insertions, 27 deletions
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.18.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.18.bb
deleted file mode 100644
index aae803f2eb..0000000000
--- a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.0.18.bb
+++ /dev/null
@@ -1,27 +0,0 @@
-SUMMARY = "Simple DirectMedia Layer truetype font library"
-SECTION = "libs"
-DEPENDS = "libsdl2 freetype virtual/egl"
-LICENSE = "Zlib"
-LIC_FILES_CHKSUM = "file://COPYING.txt;md5=e98cfd01ca78f683e9d035795810ce87"
-
-SRC_URI = "http://www.libsdl.org/projects/SDL_ttf/release/SDL2_ttf-${PV}.tar.gz \
- file://automake_foreign.patch \
- "
-SRC_URI[sha256sum] = "7234eb8883514e019e7747c703e4a774575b18d435c22a4a29d068cb768a2251"
-
-S = "${WORKDIR}/SDL2_ttf-${PV}"
-
-inherit autotools pkgconfig features_check
-
-# links to libGL.so
-REQUIRED_DISTRO_FEATURES += "opengl"
-
-do_configure:prepend() {
- # Removing these files fixes a libtool version mismatch.
- MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
-
- for i in ${MACROS}; do
- rm -f ${S}/acinclude/$i
- done
-}
-ASNEEDED = ""
diff --git a/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.20.0.bb b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.20.0.bb
new file mode 100644
index 0000000000..4728022a27
--- /dev/null
+++ b/meta-oe/recipes-graphics/libsdl/libsdl2-ttf_2.20.0.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Simple DirectMedia Layer truetype font library"
+SECTION = "libs"
+DEPENDS = "libsdl2 freetype virtual/egl"
+LICENSE = "Zlib"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=771dca8728b18d39b130e19b36514371"
+
+SRC_URI = " \
+ git://github.com/libsdl-org/SDL_ttf.git;branch=main;protocol=https \
+ git://github.com/libsdl-org/freetype.git;branch=VER-2-12-1-SDL;destsuffix=git/external/freetype;name=freetype;protocol=https \
+ git://github.com/libsdl-org/harfbuzz.git;branch=2.9.1-SDL;destsuffix=git/external/harfbuzz;name=harfbuzz;protocol=https \
+ file://automake_foreign.patch \
+"
+SRCREV = "f5e4828ffc9d3a84f00011fede4446aecb4a685f"
+SRCREV_freetype = "6fc77cee03e078e97afcee0c0e06a2d3274b9a29"
+SRCREV_harfbuzz = "6022fe2f68d028ee178284f297b3902ffdf65b03"
+
+S = "${WORKDIR}/git"
+
+inherit autotools pkgconfig features_check
+
+# links to libGL.so
+REQUIRED_DISTRO_FEATURES += "opengl"
+
+do_configure:prepend() {
+ # Removing these files fixes a libtool version mismatch.
+ MACROS="libtool.m4 lt~obsolete.m4 ltoptions.m4 ltsugar.m4 ltversion.m4"
+
+ for i in ${MACROS}; do
+ rm -f ${S}/acinclude/$i
+ done
+}
+ASNEEDED = ""