aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/lvgl
diff options
context:
space:
mode:
authorPhilippe Coval <philippe.coval@huawei.com>2021-10-20 12:48:35 +0200
committerKhem Raj <raj.khem@gmail.com>2021-11-15 08:57:25 -0800
commitd4f9519079c7de825fa34856aaf18eee4f9380a4 (patch)
treeeb38437ecab7ced00915df3beb6fc0fc46020447 /meta-oe/recipes-graphics/lvgl
parente0ab236378f8a734b72e3b392c900540bd41f87e (diff)
downloadmeta-openembedded-contrib-d4f9519079c7de825fa34856aaf18eee4f9380a4.tar.gz
lvgl: Support external wayland config
This part should be reverted once xdg-shell is supported in lvgl Relate-to: https://github.com/lvgl/lvgl/issues/2534 Forwarded: https://github.com/openembedded/meta-openembedded/pull/483 Origin: https://git.ostc-eu.org/distro/oniro/-/merge_requests/355 Signed-off-by: Philippe Coval <philippe.coval@huawei.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/lvgl')
-rw-r--r--meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
index 7e0a980d23..7ccee6bf11 100644
--- a/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
+++ b/meta-oe/recipes-graphics/lvgl/lv-drivers_7.11.0.bb
@@ -21,6 +21,9 @@ inherit features_check
S = "${WORKDIR}/${PN}-${PV}"
+LVGL_CONFIG_WAYLAND_HOR_RES ?= "480"
+LVGL_CONFIG_WAYLAND_VER_RES ?= "320"
+
EXTRA_OECMAKE += "-Dinstall:BOOL=ON"
TARGET_CFLAGS += "-DLV_CONF_INCLUDE_SIMPLE=1"
@@ -33,6 +36,8 @@ do_configure:append() {
[ -r "${S}/lv_drv_conf.h" ] \
|| sed -e "s|#if 0 .*Set it to \"1\" to enable the content.*|#if 1 // Enabled by ${PN}|g" \
-e "s|# define USE_WAYLAND 0|# define USE_WAYLAND 1|g" \
+ -e "s|\(^ *# *define *WAYLAND_HOR_RES *\).*|\1${LVGL_CONFIG_WAYLAND_HOR_RES}|g" \
+ -e "s|\(^ *# *define *WAYLAND_VER_RES *\).*|\1${LVGL_CONFIG_WAYLAND_VER_RES}|g" \
< "${S}/lv_drv_conf_template.h" > "${S}/lv_drv_conf.h"
}