aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/mesa
diff options
context:
space:
mode:
authorKoen Kooi <koen@dominion.thruhere.net>2011-06-23 22:54:28 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2011-06-23 22:54:28 +0200
commit829be3bb913fb403ed12642ede913c10eff66118 (patch)
treeb8373796a1a18303efd9f65cee7e355da1d1cd48 /meta-oe/recipes-graphics/mesa
parent5b857eeeb7b03eb5bc43a98888290b022bf42450 (diff)
downloadmeta-openembedded-contrib-829be3bb913fb403ed12642ede913c10eff66118.tar.gz
mesa-dri: sync packaging with OE-core, prepare for further PACKAGE_ARCH cleaning
Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
Diffstat (limited to 'meta-oe/recipes-graphics/mesa')
-rw-r--r--meta-oe/recipes-graphics/mesa/mesa-dri.inc18
-rw-r--r--meta-oe/recipes-graphics/mesa/mesa-dri_7.10.2.bb2
2 files changed, 18 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/mesa/mesa-dri.inc b/meta-oe/recipes-graphics/mesa/mesa-dri.inc
index 4c5934da13..8aa82c007a 100644
--- a/meta-oe/recipes-graphics/mesa/mesa-dri.inc
+++ b/meta-oe/recipes-graphics/mesa/mesa-dri.inc
@@ -7,5 +7,21 @@ FILESPATH =. "${FILE_DIRNAME}/mesa:${FILE_DIRNAME}/mesa-${PV}:"
# most of our targets do not have DRI so will use mesa-xlib
DEFAULT_PREFERENCE = "-1"
+MACHINE_DRI_MODULES ?= ""
+#PACKAGE_ARCH = "${@['${MACHINE_ARCH}','${BASE_PACKAGE_ARCH}'][bb.data.getVar('MACHINE_DRI_MODULES',d,1) == '']}"
PACKAGE_ARCH = "${MACHINE_ARCH}"
-EXTRA_OECONF += " --with-driver=dri --with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+
+EXTRA_OECONF += "--with-driver=dri --disable-egl --disable-gallium -with-dri-drivers=swrast,${MACHINE_DRI_MODULES}"
+
+python populate_packages_prepend() {
+ import os.path
+
+ dri_drivers_root = os.path.join(bb.data.getVar('libdir', d, 1), "dri")
+
+ do_split_packages(d, dri_drivers_root, '^(.*)_dri\.so$', 'mesa-dri-driver-%s', 'Mesa %s DRI driver', extra_depends='')
+}
+
+PACKAGES_DYNAMIC = "mesa-dri-driver-*"
+
+FILES_${PN}-dbg += "${libdir}/dri/.debug/*"
+
diff --git a/meta-oe/recipes-graphics/mesa/mesa-dri_7.10.2.bb b/meta-oe/recipes-graphics/mesa/mesa-dri_7.10.2.bb
index 26b56e426c..bd62c98ce4 100644
--- a/meta-oe/recipes-graphics/mesa/mesa-dri_7.10.2.bb
+++ b/meta-oe/recipes-graphics/mesa/mesa-dri_7.10.2.bb
@@ -1,4 +1,4 @@
require mesa-common.inc
require mesa-${PV}.inc
require mesa-dri.inc
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"