aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
diff options
context:
space:
mode:
authorAdrian Ratiu <adrian.ratiu@collabora.com>2019-09-30 10:18:03 +0300
committerKhem Raj <raj.khem@gmail.com>2019-09-30 16:54:51 -0700
commit43375a4271f2507383027e33ffaa87fa2a006b48 (patch)
tree9e02cabdb4bc9411ede380fd3d320a0462e6d88c /meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
parent783c4ea997243bb1266a801e0eb317bde908dcf3 (diff)
downloadmeta-openembedded-contrib-43375a4271f2507383027e33ffaa87fa2a006b48.tar.gz
renderdoc: add new recipe
RenderDoc is a MIT licensed stand-alone multi-platform graphics debugger that allows easy frame by frame capture and detailed introspection of any applications using Vulkan, OpenGL, OpenGL ES, and others. Signed-off-by: Adrian Ratiu <adrian.ratiu@collabora.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb')
-rw-r--r--meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
new file mode 100644
index 0000000000..b6e0c92f6d
--- /dev/null
+++ b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.4.bb
@@ -0,0 +1,35 @@
+SUMMARY = "RenderDoc recipe providing renderdoccmd"
+DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
+HOMEPAGE = "https://github.com/baldurk/renderdoc"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE.md;md5=9753b1b4fba3261c27d1ce5c1acef667"
+
+SRCREV = "214d85228538e71cc63a0d7fa11dd75b1d56cc81"
+SRC_URI = "git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
+ file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
+"
+S = "${WORKDIR}/git"
+
+DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
+
+RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
+
+inherit cmake python3native
+
+python __anonymous () {
+ # only works on glibc systems
+ if d.getVar('TCLIBC') != "glibc":
+ raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
+}
+
+COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
+
+EXTRA_OECMAKE += "\
+ -DENABLE_QRENDERDOC=OFF \
+ -DENABLE_PYRENDERDOC=OFF \
+ -DENABLE_RENDERDOCCMD=ON \
+ -DCMAKE_BUILD_TYPE=Release \
+"
+
+FILES_${PN} += "${libdir}"
+FILES_${PN}-dev = "${includedir}"