aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2013-02-04 18:05:04 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-02-06 15:16:01 +0100
commit61911b23099c2658186179504ded318c987b5276 (patch)
treeaa06906b8a9f0e08253b560fd519a6f03f233d80 /meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
parent4128325a4c87bcde6ac6ffe5dbf5d6d057ee4804 (diff)
downloadmeta-openembedded-contrib-61911b23099c2658186179504ded318c987b5276.tar.gz
ttf: introduce update-fonts bbclass and change all ttf recipes to use it
* without this ttf.inc had to set RRECOMMENDS and postinst/postrm without PN suffix to cover all subpackages created in ttf recipes Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb')
-rw-r--r--meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
index 9103dabfeb..6f12d29be2 100644
--- a/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
+++ b/meta-oe/recipes-graphics/ttf-fonts/ttf-mplus_027.bb
@@ -6,16 +6,20 @@ LICENSE = "${PN}"
LIC_FILES_CHKSUM = "file://LICENSE_E;md5=ac161e96eda00db9a3aec7870b5d9658 \
file://LICENSE_J;md5=a120ca8d7c8e4a475d5277c9aeb95221 \
"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://osdn.dl.sourceforge.jp/mplus-fonts/6650/mplus-TESTFLIGHT-${PV}.tar.gz"
S = "${WORKDIR}/mplus-TESTFLIGHT-${PV}"
python populate_packages_prepend() {
plugindir = d.expand('${datadir}/fonts/ttf-mplus/')
- do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common")
+ packages = do_split_packages(d, plugindir, '^(.*)\.ttf$', 'ttf-%s', 'TTF Font %s', extra_depends = "ttf-common")
+ d.setVar('UPDATE_FONTS_PACKAGES', ' '.join(packages))
}
+# for update-fonts.bbclass sake only, replaced later in populate_packages_prepend
+UPDATE_FONTS_PACKAGES = "${PN}"
+
do_install() {
install -d ${D}${datadir}/fonts/ttf-mplus
install -m 0644 *.ttf ${D}${datadir}/fonts/ttf-mplus/