aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2017-06-30 05:59:51 -0700
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:43:21 +0200
commit9fc1d268bb2597a4eeeba8ba7f62ead7bb14085f (patch)
treead4b8cf6ac1a9a5fe204b0ab17b2ea1173ad4a8c /meta-oe/recipes-graphics
parent69d7273a599265ecc8e128b20701f1c036609b4c (diff)
downloadmeta-openembedded-contrib-9fc1d268bb2597a4eeeba8ba7f62ead7bb14085f.tar.gz
assimp: Upgrade to 3.3.1 release
License years changed see https://github.com/assimp/assimp/commit/189340a99f335cc28cae7c39eaee434322a54548 Fix build on big-endian architectures Use Assimp namespace to fix build for big-endian architectures Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch29
-rw-r--r--meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb (renamed from meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb)10
2 files changed, 35 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch b/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch
new file mode 100644
index 0000000000..c94bb3d58b
--- /dev/null
+++ b/meta-oe/recipes-graphics/assimp/assimp/0001-Fix-build-on-big-endian-architectures.patch
@@ -0,0 +1,29 @@
+From 614475dcac1cee4d63b764282c578672bc060321 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Thu, 29 Jun 2017 14:23:00 -0700
+Subject: [PATCH] Fix build on big-endian architectures
+
+see
+https://github.com/assimp/assimp/pull/986
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+ code/glTFAsset.inl | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/code/glTFAsset.inl b/code/glTFAsset.inl
+index d52c825c..470246c9 100644
+--- a/code/glTFAsset.inl
++++ b/code/glTFAsset.inl
+@@ -40,6 +40,8 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+
+ #include "StringUtils.h"
+
++using namespace Assimp;
++
+ namespace glTF {
+
+ namespace {
+--
+2.13.2
+
diff --git a/meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb b/meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb
index 4da3dc213e..064683a65f 100644
--- a/meta-oe/recipes-graphics/assimp/assimp_3.1.1.bb
+++ b/meta-oe/recipes-graphics/assimp/assimp_3.3.1.bb
@@ -3,13 +3,15 @@ DESCRIPTION = "Open Asset Import Library is a portable Open Source library to im
HOMEPAGE = "http://www.assimp.org/"
SECTION = "devel"
LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=bc4231a2268da8fc55525ad119638a87"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=4cd8c0aedc7a0623476669377d7eeda8"
DEPENDS = "boost virtual/libgl"
-SRC_URI = "http://sourceforge.net/projects/${BPN}/files/${BPN}-3.1/${BPN}-${PV}_no_test_models.zip"
-SRC_URI[md5sum] = "ccd4788204509da58a3a53c7aeda7a8b"
-SRC_URI[sha256sum] = "da9827876f10a8b447270368753392cfd502e70a2e9d1361554e5dfcb1fede9e"
+SRCREV = "a8673d4828df5107186f49e5e4efa5316b727482"
+SRC_URI = "git://github.com/assimp/assimp \
+ file://0001-Fix-build-on-big-endian-architectures.patch \
+ "
+S = "${WORKDIR}/git"
inherit cmake