aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch
diff options
context:
space:
mode:
authorYongxin Liu <yongxin.liu@windriver.com>2019-07-08 14:39:00 +0800
committerKhem Raj <raj.khem@gmail.com>2019-07-10 09:24:33 -0700
commit415e213ad75ec9a93171c963395a1c4b92c6233b (patch)
tree96228c88058c0bbd1c3fc441a21e13c24d8143be /meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch
parent64d8fc68a6134ab06a9e625645a849f95cbe1059 (diff)
downloadmeta-openembedded-contrib-415e213ad75ec9a93171c963395a1c4b92c6233b.tar.gz
keyutils: move recipe and patches from meta-security to meta-oe
keyutils is originally in https://git.yoctoproject.org/git/meta-security. Move it to meta-oe since other recipes in OE depend on it. Signed-off-by: Yongxin Liu <yongxin.liu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch')
-rw-r--r--meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch b/meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch
new file mode 100644
index 0000000000..938fe2eb57
--- /dev/null
+++ b/meta-oe/recipes-security/keyutils/files/fix_library_install_path.patch
@@ -0,0 +1,28 @@
+From b0355cc205543ffd33752874295139d57c4fbc3e Mon Sep 17 00:00:00 2001
+From: Wenzong Fan <wenzong.fan@windriver.com>
+Date: Tue, 26 Sep 2017 07:59:51 +0000
+Subject: [PATCH] Subject: [PATCH] keyutils: use relative path for link
+
+The absolute path of the symlink will be invalid
+when populated in sysroot, so use relative path instead.
+
+Upstream-Status: Pending
+
+Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
+Signed-off-by: Wenzong Fan <wenzong.fan@windriver.com>
+{rebased for 1.6]
+Signed-off-by: Armin Kuster <akuster808@gmail.com>
+
+Index: keyutils-1.6/Makefile
+===================================================================
+--- keyutils-1.6.orig/Makefile
++++ keyutils-1.6/Makefile
+@@ -184,7 +184,7 @@ ifeq ($(NO_SOLIB),0)
+ $(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
+ $(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
+ mkdir -p $(DESTDIR)$(USRLIBDIR)
+- $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
++ $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
+ sed \
+ -e 's,@VERSION\@,$(VERSION),g' \
+ -e 's,@prefix\@,$(PREFIX),g' \