aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-03-10 11:27:06 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-14 12:15:38 +0100
commit7ebeb6ba4bca44cd304b73aa596de78fd977ab85 (patch)
tree46eed52bc4f4019e45302d626b62a432149d0af5 /meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
parent708aca79d3f13ca6403f1c05ef4ce995c509112b (diff)
downloadmeta-openembedded-contrib-7ebeb6ba4bca44cd304b73aa596de78fd977ab85.tar.gz
dfu-util: upgrade to 0.9
* drop commit 0792623dfa8156fb0af3f3949c901665e2df3d04 Author: Stefan `Sec` Zehl <sec@42.org> Date: Wed Jul 29 01:39:11 2015 +0200 Fix/reimplement USBPATH support Using libusb functions to retrieve port and bus numbers. Thanks to Topi Kuutela for reviewing and testing the patch. Also thanks to Timo Poikola and Topi Kuutela for having submitted alternative patches. https://sourceforge.net/p/dfu-util/tickets/6/ Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb')
-rw-r--r--meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
new file mode 100644
index 0000000000..7a7a662ab3
--- /dev/null
+++ b/meta-oe/recipes-support/dfu-util/dfu-util-native_0.9.bb
@@ -0,0 +1,16 @@
+require dfu-util_${PV}.bb
+
+inherit native deploy
+
+DEPENDS = "libusb1-native"
+
+SRC_URI += "file://0001-Revert-Makefile.am-Drop-static-dfu-util.patch"
+
+do_deploy[sstate-outputdirs] = "${DEPLOY_DIR_TOOLS}"
+do_deploy() {
+ install -d ${DEPLOY_DIR_TOOLS}
+ install -m 0755 src/dfu-util_static ${DEPLOY_DIR_TOOLS}/dfu-util-${PV}
+ rm -f ${DEPLOY_DIR_TOOLS}/dfu-util
+ ln -sf ./dfu-util-${PV} ${DEPLOY_DIR_TOOLS}/dfu-util
+}
+addtask deploy before do_package after do_install