aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-01-20 05:03:09 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-01 15:58:03 +0100
commit484fbf697925b116083925efdca211938e797c0f (patch)
treec1532a765ae713f9aa2fea80eae5082b5f16e55a /meta-oe/recipes-support/fbset
parent9cf9d864d57d2b431ad9c0a78c72e335451abe5b (diff)
downloadmeta-openembedded-contrib-484fbf697925b116083925efdca211938e797c0f.tar.gz
fbset: Fix out of tree builds ( S != B )
Remove assumption about glibc == linux Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/fbset')
-rw-r--r--meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch34
-rw-r--r--meta-oe/recipes-support/fbset/fbset_2.1.bb7
2 files changed, 38 insertions, 3 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch b/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch
new file mode 100644
index 0000000000..7f45dbea82
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset/0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch
@@ -0,0 +1,34 @@
+From 06edd88833da93361d5408b880fbb890df332497 Mon Sep 17 00:00:00 2001
+From: Khem Raj <raj.khem@gmail.com>
+Date: Tue, 19 Jan 2016 01:55:47 +0000
+Subject: [PATCH] fbset: including asm/types.h is needed on all linux systems
+
+including asm/types.h is needed to get Linux typedef's like
+__s32 and so on which are independent of C library therefore this
+define should not be guarded by __GLIBC__ but by __linux__
+
+Helps to compile it on musl systems
+
+Signed-off-by: Khem Raj <raj.khem@gmail.com>
+---
+Upstream-Status: Pending
+
+ fbset.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/fbset.h b/fbset.h
+index 9b1d2ac..0d8def8 100644
+--- a/fbset.h
++++ b/fbset.h
+@@ -15,7 +15,7 @@
+ #include <stdio.h>
+ #include <sys/types.h>
+
+-#ifdef __GLIBC__
++#ifdef __linux__
+ #include <asm/types.h>
+ #endif
+
+--
+2.7.0
+
diff --git a/meta-oe/recipes-support/fbset/fbset_2.1.bb b/meta-oe/recipes-support/fbset/fbset_2.1.bb
index 18559326a1..cbbe6caeee 100644
--- a/meta-oe/recipes-support/fbset/fbset_2.1.bb
+++ b/meta-oe/recipes-support/fbset/fbset_2.1.bb
@@ -16,15 +16,16 @@ PR = "r4"
SRC_URI = "http://ftp.debian.org/debian/pool/main/f/fbset/fbset_2.1.orig.tar.gz \
file://makefile.patch \
file://fbset-2.1-fix-makefile-dep.patch \
+ file://0001-fbset-including-asm-types.h-is-needed-on-all-linux-s.patch \
"
inherit update-alternatives
do_install() {
install -d ${D}${sbindir} ${D}${datadir}/man/man8 ${D}${datadir}/man/man5
- install -m 0755 ${WORKDIR}/${BP}/fbset ${D}${sbindir}/fbset.real
- install -m 0644 ${WORKDIR}/${BP}/*.5 ${D}${datadir}/man/man5
- install -m 0644 ${WORKDIR}/${BP}/*.8 ${D}${datadir}/man/man8
+ install -m 0755 ${B}/fbset ${D}${sbindir}/fbset.real
+ install -m 0644 ${B}/*.5 ${D}${datadir}/man/man5
+ install -m 0644 ${B}/*.8 ${D}${datadir}/man/man8
}
ALTERNATIVE_fbset = "fbset"