aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb
diff options
context:
space:
mode:
authorhasan.men <hasan.men@bosphorusiss.com>2021-03-26 10:07:57 +0100
committerKhem Raj <raj.khem@gmail.com>2021-04-06 09:02:12 -0700
commit3e5209b691c9f4c720335d4f00dc143264c2df96 (patch)
treea921d8b3c03ce9343816930cd56387dfaf03b7ce /meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb
parentcf0b587ddd9691a82db1c651f3c3b1ffb94196ee (diff)
downloadmeta-openembedded-contrib-3e5209b691c9f4c720335d4f00dc143264c2df96.tar.gz
librdkafka: Add initial recipe v1.6.1
* A patch is added to fix absolute path usage in cmake. Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb')
-rw-r--r--meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb b/meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb
new file mode 100644
index 0000000000..5314f4a48a
--- /dev/null
+++ b/meta-oe/recipes-support/librdkafka/librdkafka_1.6.1.bb
@@ -0,0 +1,23 @@
+SUMMARY = "the Apache Kafka C/C++ client library"
+DESCRIPTION = "librdkafka is a C library implementation of the Apache Kafka protocol, providing Producer, Consumer and Admin clients."
+HOMEPAGE = "https://github.com/edenhill/librdkafka"
+SECTION = "libs"
+LICENSE = "BSD-2-Clause"
+
+LIC_FILES_CHKSUM = " \
+file://LICENSE;md5=2be8675acbfdac48935e73897af5f646 \
+"
+
+SRC_URI = "git://github.com/edenhill/librdkafka;protocol=https \
+ file://0001_fix_absolute_path_usage.patch"
+SRCREV = "1a722553638bba85dbda5050455f7b9a5ef302de"
+
+DEPENDS = "zlib openssl zstd"
+
+inherit cmake
+
+S = "${WORKDIR}/git"
+
+FILES_${PN} += "${datadir}"
+
+EXTRA_OECMAKE += "-DRDKAFKA_BUILD_EXAMPLES=OFF -DRDKAFKA_BUILD_TESTS=OFF" \ No newline at end of file