aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2016-10-14 12:30:45 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2016-10-25 15:31:16 +0200
commit8cefb2e9c1d06f2ec05ed346088b676f6fc934af (patch)
treea6a6b1c7e9104b25906c560fed8c1384466795f8 /meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
parent1872a8a114061197be40f5cfc902f569f840150b (diff)
downloadmeta-openembedded-contrib-8cefb2e9c1d06f2ec05ed346088b676f6fc934af.tar.gz
libsoc: update to version 0.8.2
* License file changed to 'LICENCE' but the terms remain the same Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb')
-rw-r--r--meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
new file mode 100644
index 0000000000..01708df35a
--- /dev/null
+++ b/meta-oe/recipes-support/libsoc/libsoc_0.8.2.bb
@@ -0,0 +1,32 @@
+SUMMARY = "Library for interfacing with common SoC peripherals"
+DESCRIPTION = "libsoc is a C library to interface with common peripherals (gpio, i2c, spi, pwm) \
+ found in SoC (System on Chips) through generic Linux Kernel interfaces."
+
+HOMEPAGE = "https://github.com/jackmitch/libsoc"
+
+LICENSE = "LGPLv2.1"
+LIC_FILES_CHKSUM = "file://LICENCE;md5=e0bfebea12a718922225ba987b2126a5"
+
+inherit autotools pkgconfig python-dir
+
+SRCREV = "fd1ad6e7823fa76d8db0d3c5884faffa8ffddafb"
+SRC_URI = "git://github.com/jackmitch/libsoc.git"
+
+S = "${WORKDIR}/git"
+
+BOARD ??= "devboard"
+
+PACKAGECONFIG ?= ""
+
+PACKAGECONFIG[disabledebug] = "--disable-debug,,"
+PACKAGECONFIG[allboardconfigs] = "--with-board-configs,,"
+PACKAGECONFIG[enableboardconfig] = "--enable-board=${BOARD},,"
+PACKAGECONFIG[python] = "--enable-python=${PYTHON_PN},,${PYTHON_PN}"
+
+PACKAGES =+ "${@bb.utils.contains('PACKAGECONFIG', 'python', \
+ '${PYTHON_PN}-libsoc-staticdev ${PYTHON_PN}-libsoc', '', d)}"
+
+RDEPENDS_${PN} = "libgcc"
+
+FILES_${PYTHON_PN}-libsoc-staticdev += "${PYTHON_SITEPACKAGES_DIR}/*/*.a"
+FILES_${PYTHON_PN}-libsoc += "${PYTHON_SITEPACKAGES_DIR}"