aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/mcelog/mcelog_1.49.bb
diff options
context:
space:
mode:
authorLiwei Song <liwei.song@windriver.com>2017-04-14 05:28:15 -0400
committerMartin Jansa <Martin.Jansa@gmail.com>2017-04-24 10:59:27 +0200
commit4ddc0a58a7af4df17647b477925293d96c049b95 (patch)
treea6c5bdcf7666a4db5fae76700cf831614ab55264 /meta-oe/recipes-support/mcelog/mcelog_1.49.bb
parentefcf4e6778a3777dfd8c91dfd775ccf96bdbe658 (diff)
downloadmeta-openembedded-contrib-4ddc0a58a7af4df17647b477925293d96c049b95.tar.gz
mcelog: upgrade to 1.49 to support Denverton SoC
Update mcelog to 1.49 to support Denverton SoC, and delete the additional patches which are already involved in v1.49. Signed-off-by: Liwei Song <liwei.song@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/mcelog/mcelog_1.49.bb')
-rw-r--r--meta-oe/recipes-support/mcelog/mcelog_1.49.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/mcelog/mcelog_1.49.bb b/meta-oe/recipes-support/mcelog/mcelog_1.49.bb
new file mode 100644
index 0000000000..84633a76c9
--- /dev/null
+++ b/meta-oe/recipes-support/mcelog/mcelog_1.49.bb
@@ -0,0 +1,35 @@
+SUMMARY = "mcelog daemon accounts memory and some other errors in various ways."
+DESCRIPTION = "mcelog is required by both 32bit x86 Linux kernels (since 2.6.30) \
+and 64bit Linux kernels (since early 2.6 kernel releases) to log machine checks \
+and should run on all Linux systems that need error handling."
+HOMEPAGE = "http://mcelog.org/"
+SECTION = "System Environment/Base"
+
+SRC_URI = "git://git.kernel.org/pub/scm/utils/cpu/mce/mcelog.git;protocol=http; \
+ file://run-ptest \
+"
+
+SRCREV = "2cfdf29b2ef98ccd5ed42cdde8bbe437e0d6412f"
+
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://README.md;md5=279840fabb191e6cd9150492d31b0e20"
+
+S = "${WORKDIR}/git"
+
+inherit autotools-brokensep ptest
+
+COMPATIBLE_HOST = '(x86_64.*|i.86.*)-linux'
+
+do_install_append() {
+ install -d ${D}${sysconfdir}/cron.hourly
+ install -m 0755 ${S}/mcelog.cron ${D}${sysconfdir}/cron.hourly/
+ sed -i 's/bash/sh/' ${D}${sysconfdir}/cron.hourly/mcelog.cron
+}
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}
+ cp -r ${S}/tests ${S}/input ${D}${PTEST_PATH}
+ sed -i 's#../../mcelog#mcelog#' ${D}${PTEST_PATH}/tests/test
+}
+
+RDEPENDS_${PN}-ptest += "${PN} make bash mce-inject"