aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ne10
diff options
context:
space:
mode:
authorCarlos Rafael Giani <dv@pseudoterminal.org>2016-02-03 18:15:25 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-27 20:44:50 +0100
commitefa3ff1462b9d2609526d8f25fbd20866088c346 (patch)
tree827232668edf7eaa3da12d6ee416b33743957837 /meta-oe/recipes-support/ne10
parent90d51ea3cda746054be32c0b2a726cb6649e628f (diff)
downloadmeta-openembedded-contrib-efa3ff1462b9d2609526d8f25fbd20866088c346.tar.gz
ne10: add recipe
Add recipe for the Ne10 library ( http://projectne10.github.io/Ne10/ ). This library provides heavily ARM NEON optimized versions of functions that are commonly used. Signed-off-by: Carlos Rafael Giani <dv@pseudoterminal.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/ne10')
-rw-r--r--meta-oe/recipes-support/ne10/ne10_1.2.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ne10/ne10_1.2.1.bb b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
new file mode 100644
index 0000000000..5bfe80af12
--- /dev/null
+++ b/meta-oe/recipes-support/ne10/ne10_1.2.1.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Library containing NEON-optimized implementations for a common set of functions"
+HOMEPAGE = "http://projectne10.github.io/Ne10/"
+LICENSE = "BSD-3-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=463ac0a7d64edc2b787c4206635ca2b1"
+SECTION = "libs"
+
+SRC_URI = "git://github.com/projectNe10/Ne10.git"
+SRCREV = "a08b29d88e3c94d32b5b8f827e7fcf0bc2b34ac2"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+NE10_TARGET_ARCH = ""
+EXTRA_OECMAKE = '-DGNULINUX_PLATFORM=ON -DNE10_BUILD_SHARED=ON -DNE10_LINUX_TARGET_ARCH="${NE10_TARGET_ARCH}"'
+
+COMPATIBLE_MACHINE_aarch64 = "(.*)"
+COMPATIBLE_MACHINE_armv7a = "(.*)"
+
+python () {
+ if any(t.startswith('armv7') for t in d.getVar('TUNE_FEATURES', True).split()):
+ d.setVar('NE10_TARGET_ARCH', 'armv7')
+ bb.note('Building Ne10 for armv7')
+ elif any(t.startswith('aarch64') for t in d.getVar('TUNE_FEATURES', True).split()):
+ d.setVar('NE10_TARGET_ARCH', 'aarch64')
+ bb.note('Building Ne10 for aarch64')
+ else:
+ raise bb.parse.SkipPackage("Incompatible with archs other than armv7 and aarch64")
+}
+
+do_install() {
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -m 0644 ${S}/inc/NE10*.h ${D}${includedir}/
+ install -m 0644 ${B}/modules/libNE10.a ${D}${libdir}/
+ install -m 0755 ${B}/modules/libNE10.so.* ${D}${libdir}/
+ cp -a ${B}/modules/libNE10.so ${D}${libdir}/
+}
+
+# ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations
+in .text [textrel]
+# ERROR: QA Issue: ELF binary 'ne10/1.2.1-r0/packages-split/ne10/usr/lib/libNE10.so.10' has relocations
+in .text [textrel]
+INSANE_SKIP_${PN} += "textrel"