aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/opencv/opencv_2.4.bb
diff options
context:
space:
mode:
authorNick D'Ademo <nickdademo@gmail.com>2013-11-28 13:38:38 +1100
committerMartin Jansa <Martin.Jansa@gmail.com>2013-12-05 19:48:08 +0100
commitf7ab0eb3bab2924ba46994c0843efe970796da36 (patch)
tree5f7a3f66ba2391d24eba2a2da86d7ab9070c842f /meta-oe/recipes-support/opencv/opencv_2.4.bb
parent99f52e58d13cb0a1cda03a6f75d8b3fb527f6dd2 (diff)
downloadmeta-openembedded-contrib-f7ab0eb3bab2924ba46994c0843efe970796da36.tar.gz
opencv: bump SRCREV and make recipe multilib build compatible
Pass LIB_SUFFIX to CMake during a multilib build so that the generated library folder has the correct suffix. Signed-off-by: Nick D'Ademo <nickdademo@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/opencv/opencv_2.4.bb')
-rw-r--r--meta-oe/recipes-support/opencv/opencv_2.4.bb10
1 files changed, 9 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/opencv/opencv_2.4.bb b/meta-oe/recipes-support/opencv/opencv_2.4.bb
index 9dd9cd0477..df89b0a431 100644
--- a/meta-oe/recipes-support/opencv/opencv_2.4.bb
+++ b/meta-oe/recipes-support/opencv/opencv_2.4.bb
@@ -9,7 +9,7 @@ ARM_INSTRUCTION_SET = "arm"
DEPENDS = "python-numpy libtool swig swig-native python bzip2 zlib glib-2.0"
-SRCREV = "c5afaa4e8dfe507e87531f7688b9cf65c1f701c6"
+SRCREV = "1253c2101b22b9e89400553fd220858cda8d6ea5"
SRC_URI = "git://github.com/Itseez/opencv.git;branch=2.4 \
file://opencv-fix-pkgconfig-generation.patch \
"
@@ -27,6 +27,8 @@ EXTRA_OECMAKE = "-DPYTHON_NUMPY_INCLUDE_DIR:PATH=${STAGING_LIBDIR}/${PYTHON_DIR}
-DWITH_GSTREAMER=OFF \
-DCMAKE_SKIP_RPATH=ON \
${@bb.utils.contains("TARGET_CC_ARCH", "-msse3", "-DENABLE_SSE=1 -DENABLE_SSE2=1 -DENABLE_SSE3=1 -DENABLE_SSSE3=1", "", d)} \
+ ${@base_conditional("libdir", "/usr/lib64", "-DLIB_SUFFIX=64", "", d)} \
+ ${@base_conditional("libdir", "/usr/lib32", "-DLIB_SUFFIX=32", "", d)} \
"
PACKAGECONFIG ??= "eigen gtk jpeg libav png tiff v4l"
@@ -88,4 +90,10 @@ RDEPENDS_python-opencv = "python-core python-numpy"
do_install_append() {
cp ${S}/include/opencv/*.h ${D}${includedir}/opencv/
sed -i '/blobtrack/d' ${D}${includedir}/opencv/cvaux.h
+
+ # Move Python files into correct library folder (for multilib build)
+ if [ "$libdir" != "/usr/lib" ]; then
+ mv ${D}/usr/lib/* ${D}/${libdir}/
+ rm -rf ${D}/usr/lib
+ fi
}