aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/openldap
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2012-10-12 10:13:12 +0200
committerKoen Kooi <koen@dominion.thruhere.net>2012-10-19 11:42:13 +0200
commit8402b7ac0f2e3b0afd9d56e16e7935e1887c7698 (patch)
treea91a90f104a11aa51c5abc40c3dfd4972f735881 /meta-oe/recipes-support/openldap
parent4cd60deb11a8a6f9134d7f6ec39255a35d921426 (diff)
downloadmeta-openembedded-contrib-8402b7ac0f2e3b0afd9d56e16e7935e1887c7698.tar.gz
PACKAGES_DYNAMIC: use regexp not glob
* bitbake uses PACKAGES_DYNAMIC as regexp ^ could make matching faster (and it will be more clear that we're expecting regexp not glob) * made all those last '-' optional, use .* (or nothing) * use += instead of = in most cases to keep ${PN}-locale from bitbake.conf:PACKAGES_DYNAMIC = "^${PN}-locale-.*" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/openldap')
-rw-r--r--meta-oe/recipes-support/openldap/openldap_2.4.23.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
index 3ef12d3a1f..8d9bd6c6b6 100644
--- a/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
+++ b/meta-oe/recipes-support/openldap/openldap_2.4.23.bb
@@ -249,7 +249,7 @@ pkg_prerm_${PN}-slapd () {
update-rc.d $D openldap remove
}
-PACKAGES_DYNAMIC = "openldap-backends openldap-backend-*"
+PACKAGES_DYNAMIC += "^openldap-backends.* ^openldap-backend-.*"
python populate_packages_prepend () {
backend_dir = bb.data.expand('${libexecdir}/openldap', d)