aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pcsc-lite
diff options
context:
space:
mode:
authorAndrey Zhizhikin <andrey.z@gmail.com>2020-01-27 17:36:06 +0000
committerKhem Raj <raj.khem@gmail.com>2020-01-27 13:10:31 -0800
commit4933ca545736903972cf609abc678f838b56f325 (patch)
tree5db290932f0821185ba26e8a98613d902cbb1e4d /meta-oe/recipes-support/pcsc-lite
parent70a5edc4b52e9a615e86284ee60f992e20da1017 (diff)
downloadmeta-openembedded-contrib-4933ca545736903972cf609abc678f838b56f325.tar.gz
pcsc-lite: update recipe to use python3
Update pcsc-lite recipe to target python3 since python2 is EOL and has been dropped from OE-Core. Signed-off-by: Laurent Bonnans <laurent.bonnans@here.com> Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pcsc-lite')
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch43
-rw-r--r--meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb7
2 files changed, 48 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch b/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
new file mode 100644
index 0000000000..3e7b0adda6
--- /dev/null
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite/0001-pcsc-spy-use-python3-only.patch
@@ -0,0 +1,43 @@
+From 75dd98876951d86890ceb30be521de57fd31e3c7 Mon Sep 17 00:00:00 2001
+From: Andrey Zhizhikin <andrey.z@gmail.com>
+Date: Mon, 27 Jan 2020 13:27:12 +0000
+Subject: [PATCH] pcsc-spy: use python3 only
+
+Python2 has been EOL and most distributions would not provide any
+support for it anymore. Since Python3 is available in all distributions
+now, switch pcsc-spy to use it exclusively.
+
+Upstream-Status: Pending
+
+Signed-off-by: Andrey Zhizhikin <andrey.z@gmail.com>
+---
+ src/spy/pcsc-spy | 9 ++-------
+ 1 file changed, 2 insertions(+), 7 deletions(-)
+
+diff --git a/src/spy/pcsc-spy b/src/spy/pcsc-spy
+index 85222c6..965138e 100755
+--- a/src/spy/pcsc-spy
++++ b/src/spy/pcsc-spy
+@@ -1,4 +1,4 @@
+-#! /usr/bin/python
++#!/usr/bin/env python3
+
+ """
+ # Display PC/SC functions arguments
+@@ -22,12 +22,7 @@ from __future__ import print_function
+ import os
+ import signal
+ import time
+-try:
+- # for Python3
+- from queue import Queue
+-except ImportError:
+- # for Python2
+- from Queue import Queue
++from queue import Queue
+ from threading import Thread
+ from operator import attrgetter
+
+--
+2.17.1
+
diff --git a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
index 5e60846561..fb8c4a202f 100644
--- a/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
+++ b/meta-oe/recipes-support/pcsc-lite/pcsc-lite_1.8.26.bb
@@ -10,7 +10,10 @@ LICENSE_${PN}-spy = "GPLv3+"
LICENSE_${PN}-spy-dev = "GPLv3+"
LIC_FILES_CHKSUM = "file://COPYING;md5=628c01ba985ecfa21677f5ee2d5202f6"
-SRC_URI = "https://pcsclite.apdu.fr/files/${BP}.tar.bz2"
+SRC_URI = "\
+ https://pcsclite.apdu.fr/files/${BP}.tar.bz2 \
+ file://0001-pcsc-spy-use-python3-only.patch \
+"
SRC_URI[md5sum] = "9d36882998449daceec267c68a21ff0d"
SRC_URI[sha256sum] = "3eb7be7d6ef618c0a444316cf5c1f2f9d7227aedba7a192f389fe3e7c0dfbbd9"
@@ -50,6 +53,6 @@ RPROVIDES_${PN} += "${PN}-systemd"
RREPLACES_${PN} += "${PN}-systemd"
RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "pcscd.socket"
-RDEPENDS_${PN}-spy +="python"
+RDEPENDS_${PN}-spy +="python3"
BBCLASSEXTEND = "native"