aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
diff options
context:
space:
mode:
authorMike Crowe <mac@mcrowe.com>2016-02-08 10:57:50 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2016-02-15 10:16:37 +0100
commit2dfb2b2dab113ad472a678b223da8822315c20a9 (patch)
tree6b1d3eab202986415e7d5fb27fcb0e3dc78fecdd /meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
parentfcee6505914e0bf4e539998ee54e0de6128441bf (diff)
downloadmeta-openembedded-contrib-2dfb2b2dab113ad472a678b223da8822315c20a9.tar.gz
pngcheck: Explicitly set EXTRA_OEMAKE as required
This recipe currently relies on EXTRA_OEMAKE having been to set to "-e MAKEFLAGS=" in bitbake.conf to operate. It is necessary to make this explicit so that the default in bitbake.conf can be changed. Signed-off-by: Mike Crowe <mac@mcrowe.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb')
-rw-r--r--meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
index 445e8ad8e8..d523b7a8f5 100644
--- a/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
+++ b/meta-oe/recipes-support/pngcheck/pngcheck_2.3.0.bb
@@ -9,6 +9,8 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/project/png-mng/${BPN}/${PV}/${BPN}-${PV}.tar.g
SRC_URI[md5sum] = "980bd6d9a3830fdce746d7fe3c9166ee"
SRC_URI[sha256sum] = "77f0a039ac64df55fbd06af6f872fdbad4f639d009bbb5cd5cbe4db25690f35f"
+EXTRA_OEMAKE = "-e MAKEFLAGS="
+
do_compile() {
oe_runmake -f Makefile.unx INCS=-I${STAGING_DIR_HOST}${incdir} LIBS=${STAGING_DIR_HOST}${libdir}/libz.a
}
@@ -19,4 +21,3 @@ do_install() {
install png-fix-IDAT-windowsize ${D}${bindir}
install pngsplit ${D}${bindir}
}
-