aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/tbb
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2016-02-25 17:37:00 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2016-03-04 09:06:22 +0100
commitdf7242fddb9048738c0cdfaf0c3c227bf78f3da7 (patch)
tree93d90103179618fe595aa26a7bfab1a0afd55418 /meta-oe/recipes-support/tbb
parent7396fc62068a41d2ad88cc03d0ca485279510d55 (diff)
downloadmeta-openembedded-contrib-df7242fddb9048738c0cdfaf0c3c227bf78f3da7.tar.gz
recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"
* Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/tbb')
-rw-r--r--meta-oe/recipes-support/tbb/tbb_4.1.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta-oe/recipes-support/tbb/tbb_4.1.bb b/meta-oe/recipes-support/tbb/tbb_4.1.bb
index 55212dc6ca..09ed6ec527 100644
--- a/meta-oe/recipes-support/tbb/tbb_4.1.bb
+++ b/meta-oe/recipes-support/tbb/tbb_4.1.bb
@@ -26,7 +26,7 @@ do_compile() {
do_install() {
install -d ${D}${includedir} ${D}${libdir}/pkgconfig
rm ${S}/include/tbb/index.html -f
- cp -a ${S}/include/tbb ${D}${includedir}
+ cp -R --no-dereference --preserve=mode,links -v ${S}/include/tbb ${D}${includedir}
install -m 0755 ${B}/build/linux_*_release/lib*.so* ${D}${libdir}
install -m 0644 ${WORKDIR}/tbb.pc ${D}${libdir}/pkgconfig
}