aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/vim
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2017-03-10 11:55:44 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2017-03-11 17:57:05 +0100
commit1dff2351aa6cdafa5a501e8956cb853ab17ed9ae (patch)
tree7809553cb44ccd9d004d4b52793c6c55195a3bf3 /meta-oe/recipes-support/vim
parent1a373a033f482981eb59ff8d9eb7a9437fa18cd4 (diff)
downloadmeta-openembedded-contrib-1dff2351aa6cdafa5a501e8956cb853ab17ed9ae.tar.gz
vim: add native BBCLASSEXTEND
* some recipes might use xxd * with stricter host binaries available in PATH: http://lists.openembedded.org/pipermail/openembedded-core/2017-March/133886.html we cannot use xxd from host and it's not so common to add it into HOSTTOOL_NONFATAL * there is also smaller solution for xxd -i (which is what I need): https://github.com/gregkh/xxdi but after creating xxdi-native recipe for this I've discovered that perl on my host as well as perlnative doesn't provide File::Slurp used by this, so adding BBCLASSEXTEND here is easier solution Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-oe/recipes-support/vim')
-rw-r--r--meta-oe/recipes-support/vim/vim_8.0.0022.bb6
1 files changed, 4 insertions, 2 deletions
diff --git a/meta-oe/recipes-support/vim/vim_8.0.0022.bb b/meta-oe/recipes-support/vim/vim_8.0.0022.bb
index 1ccc52cd99..920391adb2 100644
--- a/meta-oe/recipes-support/vim/vim_8.0.0022.bb
+++ b/meta-oe/recipes-support/vim/vim_8.0.0022.bb
@@ -99,12 +99,14 @@ FILES_${PN}-common = " \
${datadir}/icons \
"
-RDEPENDS_${PN} = "ncurses-terminfo-base"
+RDEPENDS_${BPN} = "ncurses-terminfo-base"
# Recommend that runtime data is installed along with vim
-RRECOMMENDS_${PN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
+RRECOMMENDS_${BPN} = "${PN}-syntax ${PN}-help ${PN}-tutor ${PN}-vimrc ${PN}-common"
ALTERNATIVE_${PN} = "vi vim"
ALTERNATIVE_TARGET = "${bindir}/${BPN}.${BPN}"
ALTERNATIVE_LINK_NAME[vi] = "${base_bindir}/vi"
ALTERNATIVE_LINK_NAME[vim] = "${bindir}/vim"
ALTERNATIVE_PRIORITY = "100"
+
+BBCLASSEXTEND = "native"